Results 1 to 3 of 3

Thread: Unity not loading!

  1. #1
    Join Date
    Mar 2011
    Beans
    802
    Distro
    Ubuntu 13.04 Raring Ringtail

    Unity not loading!

    I am using Ubuntu 11.10 desktop edition x64, and every time I try to log in using default settings, Unity never loads properly, so I cannot use my computer. Right when I click "enter" to log in, the screen turns gray for a few seconds and my desktop background appears. Then, a bar on the top flashes into place, featuring the global menu and nothing else. The unity launcher never appears and the global menu does not feature the Ubuntu colors: Only an ugly shade of gray. No system tray icons appear. No power button, nothing else.

    All this happened after I decided to install the proper ATI drivers for my graphics chip, then uninstalled the proprietary driver after a glitch caused the system to slow down.

    I can still access nautilus and the terminal.

    Is there any way I can fix this problem without completely re-installing my system? I do not want to reconfigure my settings.
    Bring Chrome to the Software Center. Now.
    https://bugs.launchpad.net/ubuntu/+s...r/+bug/1186564

  2. #2
    Join Date
    Nov 2008
    Location
    California, USA
    Beans
    194
    Distro
    Ubuntu 13.04 Raring Ringtail

    Re: Unity not loading!

    I'm having the same problem. I don't think it has anything to do with graphics drivers. hmmm....

  3. #3
    Join Date
    Nov 2008
    Location
    California, USA
    Beans
    194
    Distro
    Ubuntu 13.04 Raring Ringtail

    Re: Unity not loading!

    i'm able to bring up terminal through the shortcut key and have tried running unity.

    Code:
    $ unity
    unity-panel-service: no process found
    Checking if settings need to be migrated ...no
    Checking if internal files need to be migrated ...no
    Backend     : gconf
    Integration : true
    Profile     : default
    Adding plugins
    Skipping upgrade com.canonical.unity.unity.01.upgrade
    Skipping upgrade com.canonical.unity.unity.02.upgrade
    Initializing core options...done
    Initializing bailer options...done
    Initializing detection options...done
    Initializing composite options...done
    compiz (core) - Error: Couldn't load plugin '/usr/lib/compiz/libopengl.so' : libGL.so.1: cannot open shared object file: No such file or directory
    compiz (core) - Error: Couldn't load plugin 'opengl'
    compiz (core) - Error: Couldn't load plugin '/usr/lib/compiz/libdecor.so' : libGL.so.1: cannot open shared object file: No such file or directory
    compiz (core) - Error: Couldn't load plugin 'decor'
    compiz (core) - Error: Couldn't load plugin '/usr/lib/compiz/libmove.so' : libGL.so.1: cannot open shared object file: No such file or directory
    compiz (core) - Error: Couldn't load plugin 'move'
    Initializing mousepoll options...done
    compiz (core) - Error: Couldn't load plugin '/usr/lib/compiz/libresize.so' : libGL.so.1: cannot open shared object file: No such file or directory
    compiz (core) - Error: Couldn't load plugin 'resize'
    Initializing gnomecompat options...done
    compiz (core) - Error: Couldn't load plugin 'annotate'
    Initializing snap options...done
    compiz (core) - Error: Couldn't load plugin '/usr/lib/compiz/libcompiztoolbox.so' : libGL.so.1: cannot open shared object file: No such file or directory
    compiz (core) - Error: Couldn't load plugin 'compiztoolbox'
    compiz (core) - Error: Couldn't load plugin 'obs'
    Initializing place options...done
    compiz (core) - Error: Couldn't load plugin 'ring'
    compiz (core) - Error: Couldn't load plugin '/usr/lib/compiz/libanimation.so' : libGL.so.1: cannot open shared object file: No such file or directory
    compiz (core) - Error: Couldn't load plugin 'animation'
    compiz (core) - Error: Couldn't load plugin '/usr/lib/compiz/libwall.so' : libGL.so.1: cannot open shared object file: No such file or directory
    compiz (core) - Error: Couldn't load plugin 'wall'
    compiz (core) - Error: Couldn't load plugin '/usr/lib/compiz/libgrid.so' : libGL.so.1: cannot open shared object file: No such file or directory
    compiz (core) - Error: Couldn't load plugin 'grid'
    Initializing vpswitch options...done
    compiz (core) - Error: Couldn't load plugin '/usr/lib/compiz/libexpo.so' : libGL.so.1: cannot open shared object file: No such file or directory
    compiz (core) - Error: Couldn't load plugin 'expo'
    compiz (core) - Error: Couldn't load plugin 'resizeinfo'
    Initializing session options...done
    compiz (core) - Error: Couldn't load plugin '/usr/lib/compiz/libworkarounds.so' : libGL.so.1: cannot open shared object file: No such file or directory
    compiz (core) - Error: Couldn't load plugin 'workarounds'
    compiz (core) - Error: Couldn't load plugin '/usr/lib/compiz/libfade.so' : libGL.so.1: cannot open shared object file: No such file or directory
    compiz (core) - Error: Couldn't load plugin 'fade'
    compiz (core) - Error: Couldn't load plugin '/usr/lib/compiz/libezoom.so' : libGL.so.1: cannot open shared object file: No such file or directory
    compiz (core) - Error: Couldn't load plugin 'ezoom'
    compiz (core) - Error: Couldn't load plugin '/usr/lib/compiz/libscale.so' : libGL.so.1: cannot open shared object file: No such file or directory
    compiz (core) - Error: Couldn't load plugin 'scale'
    compiz (core) - Error: Couldn't load plugin '/usr/lib/compiz/libunityshell.so' : libGL.so.1: cannot open shared object file: No such file or directory
    compiz (core) - Error: Couldn't load plugin 'unityshell'
    Setting Update "main_menu_key"
    Setting Update "run_key"
    ^[O1;3Q
    I guess this might have something to do with a game that i installed that used opengl. The game was hammer of thyrion, a hexen 2 port.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •