Results 1 to 9 of 9

Thread: HTTPS sites like FB and Hotmail not loading properly

  1. #1
    Join Date
    Jun 2011
    Beans
    6

    Unhappy HTTPS sites like FB and Hotmail not loading properly

    Greetings,
    I am using Lenovo G550 laptop wid Intel Dual Core 2GHz, 2GB RAM, 250GB HDD, etc. Earlier I had 2 partitions 187GB (Windows 7) and other 33GB of Lenovo drivers. I split 187GB to 143GB (Windows 7) while remaining 44GB for Ubuntu 10.10!
    Everything's been working fine except for internet. I am unable to load many https sites like fb, hotmail, etc. Gmail is working absolutely fine.
    I did some research on this forum and disabled ipv6! I also checked for firewall and it was disabled. Then I also configured Open DNS and checked if it is working fine. But nothing has helped.
    When I connect to these sites without 's' in https (i.e. only http) these sites load fast. I enter my username n password and then I am redirected to a compulsory https site which then takes me to a page like this (shown in thumbnails)! I have tried Chrome n Firefox 3.6 (which have SSL and TLS checked in preferences)! All these sites are working fine on Windows 7. But I don't want to use Windows 7 every now and then because it has become too slow and boring! Please help me with this.
    I connect to internet using DSL wired (BSNL Broadband 256Kbps)
    Thanking in advance!
    Attached Images Attached Images

  2. #2
    Join Date
    Aug 2005
    Beans
    445
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: HTTPS sites like FB and Hotmail not loading properly

    I also checked for firewall and it was disabled.
    And how about your modem/router that connects you to the internet. Could that be blocking the secure socket layer port?

  3. #3
    Join Date
    Jun 2011
    Beans
    6

    Re: HTTPS sites like FB and Hotmail not loading properly

    Quote Originally Posted by carverj View Post
    And how about your modem/router that connects you to the internet. Could that be blocking the secure socket layer port?
    I am using Huawei SmartAX MT882. I don't think that modem is blocking it! Because Gmail is working fine with https. Also on windows 7 all the sites are working fine with same modem.

  4. #4
    Join Date
    Mar 2007
    Location
    INDIA-Kerala
    Beans
    1,604
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: HTTPS sites like FB and Hotmail not loading properly

    How do you connect to internet?Do you use a PPPoE dialler(modem in bridge mode) or Is the connection always ON (Modem in PPPoE mode with username and password stored in it)?
    You may try a different MTU (default is 1500, so try 1492 or 1482).
    If your modem is in bridge mode and if you are using network manager DSL connection,click network manager icon-edit connections-DSL tab-select the connection-edit-wired tab-change MTU to 1492 and apply.
    If you are using PPPoE mode ,click network manager icon-edit connections-wired tab-select the connection-edit-wired tab-change MTU and apply.
    Run
    Code:
    sudo service network-manager restart
    and see if there is any difference
    Registered linux user #518022

  5. #5
    Join Date
    Aug 2007
    Location
    Canada
    Beans
    48
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: HTTPS sites like FB and Hotmail not loading properly

    Looks like the issue is with displaying https pages on Facebook and Hotmail/Live.com. One of the errors that I see from my browser is NS_ERROR_NET_TIMEOUT. This issue occurs when using both Firefox and Chrome (I tried in Opera and it doesn't work either).

  6. #6
    Join Date
    Jun 2011
    Beans
    6

    Re: HTTPS sites like FB and Hotmail not loading properly

    I tried in Opera and it doesn't work either).
    I also tried Opera. FB works only sometimes when i reboot! It doesn't work afterwards. Why are the stylesheets not loading? It loads only text! How to overcome the timeout issue?

  7. #7
    Join Date
    Jun 2011
    Beans
    1

    Re: HTTPS sites like FB and Hotmail not loading properly

    same problem on same 10.10 version

  8. #8
    Join Date
    Aug 2007
    Location
    Canada
    Beans
    48
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: HTTPS sites like FB and Hotmail not loading properly

    I noticed that the issue is now fixed (using firefox 5)

  9. #9
    Join Date
    Jun 2011
    Beans
    6

    Re: HTTPS sites like FB and Hotmail not loading properly

    Quote Originally Posted by Sepiraph View Post
    I noticed that the issue is now fixed (using firefox 5)
    Yes! The problem has been solved thanks to the new version of firefox.
    (I think the problem occurs when linux communicates with an ASP .NET Microsoft server)

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •