Results 1 to 5 of 5

Thread: Can't create menu launcher for Machinarium?

  1. #1
    Join Date
    Dec 2006
    Location
    WA state
    Beans
    Hidden!
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Can't create menu launcher for Machinarium?

    I have the Machinarium folder located in my home folder and if I run the executable from there, the game starts up just fine. But, for some reason trying to create a menu launcher linking to that exact same file results in nothing but a black screen. Any ideas?

  2. #2
    Join Date
    Oct 2004
    Location
    Denmark - Scandinavia
    Beans
    19,461

    Re: Can't create menu launcher for Machinarium?

    What did you add as a command in the launcher?
    | AMD Ryzen 1700x 3.4 GHz | ASUS PRIME X370-A | 32 GB 2400 Mhz DDR4 |
    | ASUS Nvidia 1070 8 GB | SSD 250 GB | HDD 1 TB |


    My favourite place of all, is the closet in the hall

  3. #3
    Join Date
    Dec 2006
    Location
    WA state
    Beans
    Hidden!
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: Can't create menu launcher for Machinarium?

    /home/<my user name>/Machinarium/Machinarium

  4. #4
    Join Date
    Oct 2004
    Location
    Denmark - Scandinavia
    Beans
    19,461

    Re: Can't create menu launcher for Machinarium?

    Try instead;
    Code:
    sh -c "cd ~/Machinarium && ./Machinarium"
    first try it via the terminal, then as a launcher command.
    | AMD Ryzen 1700x 3.4 GHz | ASUS PRIME X370-A | 32 GB 2400 Mhz DDR4 |
    | ASUS Nvidia 1070 8 GB | SSD 250 GB | HDD 1 TB |


    My favourite place of all, is the closet in the hall

  5. #5
    Join Date
    Dec 2006
    Location
    WA state
    Beans
    Hidden!
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: Can't create menu launcher for Machinarium?

    Quote Originally Posted by Artificial Intelligence View Post
    Try instead;
    Code:
    sh -c "cd ~/Machinarium && ./Machinarium"
    first try it via the terminal, then as a launcher command.
    That worked like a charm! Thank you so much! Would you mind explaining what that just did and where I went wrong before? I'd greatly appreciate it!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •