Hi! First of all, I'm new to Ubuntu Forums and don't know if this is the right place to post this. So my apologies if it's not..

The problem is, I have used Ubuntu from 6.10 upto 11.10. And upto 11.04 I used my same USB 3G dongle to connect to broadband and it worked fine. But 2 days ago I upgraded to Ubuntu 11.10 and broadband is not working. It detects my dongle and creates a connection without a problem, but when connecting it just keeps on and on for a long time and then say I'm offline. So I did a clean install and the same thing occurred. But I also have a netbook and its got Ubuntu 11.10. I tried using the same dongle for internet on that netbook and it worked fine without any issues.

My hardware:
Main computer (one that I'm trying to connect):
2.8GHz dual core Intel
500GB Sata II HDD
384MB Video Memory (Intel G31/G33 chipset)
Ubuntu 11.10 (32bit)

My NetBook (broadband working fine):
1.6GHz Intel Atom (dual core)
128MB Video Memory (Intel something-I-can't-remember)
Ubuntu 11.10 (32bit)

My dongle is a Huawei E220 and ISP is Dialog GSM (I'm in Sri Lanka)

So any idea why this is? I really love Ubuntu and this is bugging me off.. Any help greatly appreciated.