Results 1 to 3 of 3

Thread: 11.10 ALSA Error WriteAudio buffer underrun

  1. #1
    Join Date
    Dec 2007
    Location
    Central California, USA
    Beans
    128
    Distro
    Xubuntu 14.04 Trusty Tahr

    Cool 11.10 ALSA Error WriteAudio buffer underrun

    Frontends work OK with remote backend (10.10) for me, so I tried loading it on my skimpy lenovo s12 (atom) except for hiccough on live tv ( http://ubuntuforums.org/showthread.php?t=1878407 )

    Got that "fixed" but now the audio skips...

    Code:
    Starting mythfrontend.real..
    2011-11-09 15:20:09.752 mythfrontend version: fixes/0.24 [v0.24.1-105-g2b55759] www.mythtv.org
    2011-11-09 15:20:09.753 Using runtime prefix = /usr
    2011-11-09 15:20:09.753 Using configuration directory = /home/user/.mythtv
    2011-11-09 15:20:09.755 ThreadPool:HTTP: Initial 1, Max 25, Timeout 60000
    2011-11-09 15:20:10.612 Using localhost value of lenovoS12
    2011-11-09 15:20:10.614 Testing network connectivity to '192.168.0.55'
    2011-11-09 15:20:10.742 New DB connection, total: 1
    2011-11-09 15:20:10.758 Connected to database 'mythconverg' at host: 192.168.0.55
    2011-11-09 15:20:10.775 Closing DB connection named 'DBManager0'
    2011-11-09 15:20:10.783 Connected to database 'mythconverg' at host: 192.168.0.55
    2011-11-09 15:20:10.810 Current locale en_US
    2011-11-09 15:20:10.811 Reading locale defaults from /usr/share/mythtv//locales/en_us.xml
    2011-11-09 15:20:11.320 ScreenSaverX11Private: Gnome screen saver support enabled
    2011-11-09 15:20:11.326 DPMS is active.
    2011-11-09 15:20:11.439 Desktop video mode: 1280x800 59.999 Hz
    2011-11-09 15:20:11.706 Enabled verbose msgs:  important general
    2011-11-09 15:20:11.875 Loading en_us translation for module mythfrontend
    2011-11-09 15:20:12.063 LIRC, Error: Failed to connect to Unix socket '/var/run/lirc/lircd'
    			eno: No such file or directory (2)
    2011-11-09 15:20:12.064 JoystickMenuThread: Joystick disabled - Failed to read /home/user/.mythtv/joystickmenurc
    2011-11-09 15:20:12.521 Using Frameless Window
    2011-11-09 15:20:12.522 Using Full Screen Window
    2011-11-09 15:20:13.038 Using the Qt painter
    2011-11-09 15:20:13.849 New DB connection, total: 2
    2011-11-09 15:20:13.856 Connected to database 'mythconverg' at host: 192.168.0.55
    2011-11-09 15:20:13.869 Current MythTV Schema Version (DBSchemaVer): 1264
    2011-11-09 15:20:15.182 ThemeInfo, Warning: Unable to open themeinfo.xml for /usr/share/mythtv/themes/BlackCurves-OSD/themeinfo.xml
    2011-11-09 15:20:15.183 ThemeInfo, Error: The theme (/usr/share/mythtv/themes/BlackCurves-OSD) is missing a themeinfo.xml file.
    2011-11-09 15:20:15.189 ThemeInfo, Warning: Unable to open themeinfo.xml for /usr/share/mythtv/themes/Gray-OSD/themeinfo.xml
    2011-11-09 15:20:15.189 ThemeInfo, Error: The theme (/usr/share/mythtv/themes/Gray-OSD) is missing a themeinfo.xml file.
    2011-11-09 15:20:16.103 Pulse: PulseAudio suspend OK
    2011-11-09 15:20:16.393 Pulse: PulseAudio resume OK
    2011-11-09 15:20:19.194 Registering Internal as a media playback plugin.
    2011-11-09 15:20:19.202 No plugins directory /usr/lib/mythtv/plugins
    2011-11-09 15:20:20.203 Found mainmenu.xml for theme 'MythCenter-wide'
    2011-11-09 15:20:20.317 MythCoreContext: Connecting to backend server: 192.168.0.55:6543 (try 1 of 1)
    2011-11-09 15:20:20.321 Using protocol version 63
    2011-11-09 15:20:38.026 Pulse: PulseAudio suspend OK
    2011-11-09 15:20:38.326 Pulse: PulseAudio resume OK
    2011-11-09 15:21:05.808 Received a remote 'Clear Cache' request
    2011-11-09 15:22:22.220 Received a remote 'Clear Cache' request
    2011-11-09 15:22:42.282 Received a remote 'Clear Cache' request
    2011-11-09 15:22:53.258 TV: Attempting to change from None to WatchingLiveTV
    2011-11-09 15:22:53.290 MythCoreContext: Connecting to backend server: 192.168.0.55:6543 (try 1 of 1)
    2011-11-09 15:22:53.297 Using protocol version 63
    2011-11-09 15:22:53.420 Spawning LiveTV Recorder -- begin
    2011-11-09 15:22:53.694 Spawning LiveTV Recorder -- end
    2011-11-09 15:22:53.873 We have a playbackURL(myth://192.168.0.55:6543/1131_20111109152253.mpg) & cardtype(DUMMY)
    2011-11-09 15:22:53.873 We have a RingBuffer
    2011-11-09 15:22:54.333 Pulse: PulseAudio suspend OK
    2011-11-09 15:22:54.835 VideoOutputXv: XVideo Adaptor Name: 'Intel(R) Textured Video'
    2011-11-09 15:22:54.979 OSD: Base theme size: 1280x720
    2011-11-09 15:22:54.979 OSD: Scaling factors: 0.5625x0.8
    2011-11-09 15:22:55.114 OSD: Base theme size: 1280x720
    2011-11-09 15:22:55.114 OSD: Scaling factors: 0.5625x0.8
    greedyhdeint: size changed from 0 x 0 -> 720 x 576
    2011-11-09 15:22:55.154 Player(0): Video timing method: USleep with busy wait
    2011-11-09 15:22:55.155 TV: Changing from None to WatchingLiveTV
    2011-11-09 15:22:55.155 TV: State is LiveTV & mctx == ctx
    2011-11-09 15:22:55.167 TV: UpdateOSDInput done
    2011-11-09 15:22:55.168 TV: UpdateLCD done
    2011-11-09 15:22:55.168 TV: ITVRestart done
    2011-11-09 15:22:55.223 MythUIHelper, Error: LoadScaleImage(/home/user/.mythtv/channels/kovr_cbs13_sacramento.jpg)Unable to find image file
    2011-11-09 15:22:55.246 MythUIHelper, Error: LoadScaleImage(/home/user/.mythtv/channels/kovr_cbs13_sacramento.jpg)Unable to find image file
    2011-11-09 15:22:55.249 MythUIHelper, Error: LoadScaleImage(/home/user/.mythtv/channels/kovr_cbs13_sacramento.jpg)Unable to find image file
    2011-11-09 15:22:55.252 MythUIHelper, Error: LoadScaleImage(/home/user/.mythtv/channels/kovr_cbs13_sacramento.jpg)Unable to find image file
    2011-11-09 15:22:55.257 MythUIHelper, Error: LoadScaleImage(/home/user/.mythtv/channels/kovr_cbs13_sacramento.jpg)Unable to find image file
    2011-11-09 15:22:55.261 MythUIHelper, Error: LoadScaleImage(/home/user/.mythtv/channels/kovr_cbs13_sacramento.jpg)Unable to find image file
    2011-11-09 15:22:55.264 MythUIHelper, Error: LoadScaleImage(/home/user/.mythtv/channels/kovr_cbs13_sacramento.jpg)Unable to find image file
    2011-11-09 15:22:55.268 MythUIHelper, Error: LoadScaleImage(/home/user/.mythtv/channels/kovr_cbs13_sacramento.jpg)Unable to find image file
    2011-11-09 15:22:55.271 MythUIHelper, Error: LoadScaleImage(/home/user/.mythtv/channels/kovr_cbs13_sacramento.jpg)Unable to find image file
    2011-11-09 15:22:55.275 MythUIHelper, Error: LoadScaleImage(/home/user/.mythtv/channels/kovr_cbs13_sacramento.jpg)Unable to find image file
    2011-11-09 15:22:55.278 MythUIHelper, Error: LoadScaleImage(/home/user/.mythtv/channels/kovr_cbs13_sacramento.jpg)Unable to find image file
    2011-11-09 15:22:55.281 MythUIHelper, Error: LoadScaleImage(/home/user/.mythtv/channels/kovr_cbs13_sacramento.jpg)Unable to find image file
    2011-11-09 15:22:55.284 MythUIHelper, Error: LoadScaleImage(/home/user/.mythtv/channels/kovr_cbs13_sacramento.jpg)Unable to find image file
    2011-11-09 15:22:55.288 MythUIHelper, Error: LoadScaleImage(/home/user/.mythtv/channels/kovr_cbs13_sacramento.jpg)Unable to find image file
    2011-11-09 15:22:55.291 MythUIHelper, Error: LoadScaleImage(/home/user/.mythtv/channels/kovr_cbs13_sacramento.jpg)Unable to find image file
    2011-11-09 15:22:55.294 MythUIHelper, Error: LoadScaleImage(/home/user/.mythtv/channels/kovr_cbs13_sacramento.jpg)Unable to find image file
    2011-11-09 15:22:55.297 MythUIHelper, Error: LoadScaleImage(/home/user/.mythtv/channels/kovr_cbs13_sacramento.jpg)Unable to find image file
    2011-11-09 15:22:55.301 MythUIHelper, Error: LoadScaleImage(/home/user/.mythtv/channels/kovr_cbs13_sacramento.jpg)Unable to find image file
    2011-11-09 15:22:55.304 ScreenSaverX11Private: DPMS Deactivated 1
    2011-11-09 15:22:55.876 [mpeg2video @ 0x319bb40]mpeg_decode_postinit() failure
    2011-11-09 15:22:55.877 [mpeg2video @ 0x319bb40]mpeg_decode_postinit() failure
    2011-11-09 15:22:55.880 [mpeg2video @ 0x319bb40]mpeg_decode_postinit() failure
    2011-11-09 15:22:55.913 [mpeg2video @ 0x319bb40]mpeg_decode_postinit() failure
    2011-11-09 15:22:55.971 [mpeg2video @ 0x319bb40]mpeg_decode_postinit() failure
    2011-11-09 15:22:55.973 [mpeg2video @ 0x319bb40]mpeg_decode_postinit() failure
    2011-11-09 15:22:56.029 [mpeg2video @ 0x319bb40]mpeg_decode_postinit() failure
    2011-11-09 15:22:56.083 [mpeg2video @ 0x319bb40]mpeg_decode_postinit() failure
    2011-11-09 15:22:56.085 [mpeg2video @ 0x319bb40]mpeg_decode_postinit() failure
    2011-11-09 15:22:56.139 [mpeg2video @ 0x319bb40]mpeg_decode_postinit() failure
    2011-11-09 15:22:56.141 [mpeg2video @ 0x319bb40]mpeg_decode_postinit() failure
    2011-11-09 15:22:56.195 [mpeg2video @ 0x319bb40]mpeg_decode_postinit() failure
    2011-11-09 15:22:56.199 [mpeg2video @ 0x319bb40]mpeg_decode_postinit() failure
    2011-11-09 15:22:56.256 [mpeg2video @ 0x319bb40]mpeg_decode_postinit() failure
    2011-11-09 15:22:56.687 VideoOutputXv: XVideo Adaptor Name: 'Intel(R) Textured Video'
    2011-11-09 15:22:56.983 OSD: Base theme size: 1280x720
    2011-11-09 15:22:56.983 OSD: Scaling factors: 1.5x1.5
    2011-11-09 15:22:57.133 AFD: Opened codec 0x9517b50, id(MPEG2VIDEO) type(Video)
    2011-11-09 15:22:57.134 AFD: codec AC3 has 6 channels
    2011-11-09 15:22:57.137 AFD: Opened codec 0x9b4c6f0, id(AC3) type(Audio)
    2011-11-09 15:22:57.137 AFD: codec AC3 has 2 channels
    2011-11-09 15:22:57.142 AFD: Opened codec 0x9a44d70, id(AC3) type(Audio)
    2011-11-09 15:22:57.337 Pulse: PulseAudio resume OK
    2011-11-09 15:22:57.539 Pulse: PulseAudio suspend OK
    2011-11-09 15:22:57.583 AO: Opening audio device 'front:CARD=Intel,DEV=0' ch 2(6) sr 48000 sf signed 32 bit reenc 0
    2011-11-09 15:22:57.586 AudioPlayer: Enabling Audio
    2011-11-09 15:22:57.710 AFD: Resetting byte context eof (livetv 1 was eof 0)
    2011-11-09 15:22:57.950 Player(0): Waited 100ms for video buffers AAAAAAAAAAAAAAAAAAAAAAAAAAAuULL
    2011-11-09 15:22:57.960 Player(0): Waited 100ms for video buffers AAAAAAAAAAAAAAAAAAAAAAAAAAAuULu
    2011-11-09 15:22:57.965 Player(0): Waited 100ms for video buffers LAAAAAAAAAAAAAAAAAAAAAAAAAAUULU
    2011-11-09 15:22:57.975 Player(0): Waited 100ms for video buffers LAAAAAAAAAAAAAAAAAAAAAAAAAAUULU
    2011-11-09 15:22:58.077 Player(0): Waited 100ms for video buffers LUuAAAAAAAAAAAAAAAAAAAAAAAAUUuU
    2011-11-09 15:22:58.087 Player(0): Waited 100ms for video buffers LUULAAAAAAAAAAAAAAAAAAAAAAAUUUU
    2011-11-09 15:22:58.101 Player(0): Waited 100ms for video buffers LUULAAAAAAAAAAAAAAAAAAAAAAAUUUU
    2011-11-09 15:22:58.205 Player(0): Waited 100ms for video buffers UUULUULAAAAAAAAAAAAAAAAAAAAUUUU
    2011-11-09 15:22:58.215 Player(0): Waited 100ms for video buffers UUULUULAAAAAAAAAAAAAAAAAAAAUUUU
    2011-11-09 15:22:58.229 Player(0): Waited 100ms for video buffers UUULUULAAAAAAAAAAAAAAAAAAAAUUUU
    2011-11-09 15:22:58.538 VideoOutput: Created YV12 OSD.
    2011-11-09 15:23:00.782 ALSA, Error: WriteAudio: buffer underrun
    2011-11-09 15:23:01.113 ALSA, Error: WriteAudio: buffer underrun
    2011-11-09 15:23:01.394 ALSA, Error: WriteAudio: buffer underrun
    2011-11-09 15:23:03.549 ALSA, Error: WriteAudio: buffer underrun
    2011-11-09 15:23:05.679 ALSA, Error: WriteAudio: buffer underrun
    2011-11-09 15:23:05.967 ALSA, Error: WriteAudio: buffer underrun
    2011-11-09 15:23:06.218 ALSA, Error: WriteAudio: buffer underrun
    2011-11-09 15:23:06.504 ALSA, Error: WriteAudio: buffer underrun
    2011-11-09 15:23:06.858 ALSA, Error: WriteAudio: buffer underrun
    2011-11-09 15:23:09.117 ALSA, Error: WriteAudio: buffer underrun
    2011-11-09 15:23:09.431 ALSA, Error: WriteAudio: buffer underrun
    2011-11-09 15:23:09.694 ALSA, Error: WriteAudio: buffer underrun
    2011-11-09 15:23:10.959 ALSA, Error: WriteAudio: buffer underrun
    2011-11-09 15:23:11.310 ALSA, Error: WriteAudio: buffer underrun
    2011-11-09 15:23:13.006 ALSA, Error: WriteAudio: buffer underrun
    2011-11-09 15:23:13.296 ALSA, Error: WriteAudio: buffer underrun
    2011-11-09 15:23:14.875 ALSA, Error: WriteAudio: buffer underrun
    2011-11-09 15:23:15.206 ALSA, Error: WriteAudio: buffer underrun
    2011-11-09 15:23:16.533 ALSA, Error: WriteAudio: buffer underrun
    2011-11-09 15:23:16.843 ALSA, Error: WriteAudio: buffer underrun
    2011-11-09 15:23:17.105 ALSA, Error: WriteAudio: buffer underrun
    2011-11-09 15:23:17.857 TV: Attempting to change from WatchingLiveTV to None
    2011-11-09 15:23:18.100 Pulse: PulseAudio resume OK
    2011-11-09 15:23:18.578 TV: Changing from WatchingLiveTV to None
    2011-11-09 15:23:18.582 ScreenSaverX11Private: DPMS Reactivated 1
    2011-11-09 15:23:22.863 Pulse: Cleaning up PulseHandler
    2011-11-09 15:23:22.864 Deleting UPnP client...
    Error in my_thread_global_end(): 1 threads didn't exit
    The odd thing is that the audio was fine before whatever caused the earlier jump program problem. And the audio's fine on the workstation (which is too big to carry into the kitchen).

    Any ideas...?


    .

  2. #2
    Join Date
    Aug 2009
    Beans
    1,419

    Re: 11.10 ALSA Error WriteAudio buffer underrun

    You may want to scan for audio devices on your frontend, and then choose ALSA:pulse as your audio source.

    If that still doesn't work, you may want to try one of the other audio sources until you find one that your frontend can handle.

  3. #3
    Join Date
    Dec 2007
    Location
    Central California, USA
    Beans
    128
    Distro
    Xubuntu 14.04 Trusty Tahr

    Smile Re: 11.10 ALSA Error WriteAudio buffer underrun

    Quote Originally Posted by thatguruguy View Post
    You may want to scan for audio devices on your frontend, and then choose ALSAulse as your audio source.

    If that still doesn't work, you may want to try one of the other audio sources until you find one that your frontend can handle.
    OK - I tried both pulse options and no go.

    But
    Code:
    ALSA:hw:Card=Intel,DEV=0
    seems to work!!!

    Point your elbow at the ceiling and pat yourself on the back!


Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •