View Poll Results: Did it work for you?

1762. You may not vote on this poll
  • Yes

    1,051 59.65%
  • No

    487 27.64%
  • I have this card, but it's already working

    69 3.92%
  • I have this card, but I don't care if it works

    19 1.08%
  • I have a different card

    136 7.72%
Results 1 to 10 of 1981

Thread: HOWTO: Broadcom 4318 Wireless Cards

Threaded View

  1. #1
    Join Date
    May 2006
    Ubuntu 10.10 Maverick Meerkat

    Lightbulb HOWTO: Broadcom 4318 Wireless Cards


    This process is vastly simplified in Hardy. The easiest way to do it is to open the Hardware Drivers program (go to the System menu in the top left corner of the screen, and click Administration, and then Hardware Drivers) and check the Broadcom B43 wireless driver box, and reboot.

    A couple of notes about that procedure:

    It installs the b43 driver, which is semi-open source. The b43 driver works decently and will cover most peoples' wireless needs, and is easy to setup. However, you can also choose to use ndiswrapper, which will provide you with a slightly faster connection. For information on how to set that up, see

    Those of you using WEP may also want to note:
    Quote Originally Posted by DrSpirograph
    However, you may want to mention that there seems to be a bit of a bug with the way NetworkManager handles WEP + DHCP.

    (See here

    The bug made me (and I suspect may make others) think that their card isn't working, when in fact it is.

    To work around and get WEP going, you can do the following:
    sudoedit /etc/network/interfaces
    add the line
    iface wlan0 inet dhcp
    then, to get the network up, do the following (replacing $ESSID and $KEY with the proper ESSID and key):
    sudo iwconfig wlan0 essid $ESSID key $KEY sudo ifup wlan0

    The information below is for versions of Ubuntu older then Hardy (Gutsy, Feisty, Edgy, Dapper)

    This HOWTO is for people who have a Broadcom 4318 Wireless card in their laptop. This card can sometimes be a bit difficult to setup, so I have provided a working method (for me, anyway).

    To check if you have a Broadcom 4318 Card, open up the terminal (click the Applications button, then Accessories, and then Terminal) and run (just copy and paste the code from the code boxes throughout the HOWTO [in the terminal, this is done by right click anywhere and clicking paste, ctrl+v doesn't work])
    lspci | grep Broadcom\ Corporation
    If your output looks similar to
    0000:05:02.0 Network controller: Broadcom Corporation BCM4318 [AirForce One 54g] 802.11g Wireless LAN Controller (rev 02)
    or you can see the string BCM4318 in the output, then this should work for you.

    Please note that this was really designed to be run on a very fresh install, right after Ubuntu has come up for the first time. It is mostly likely to work then. If you have tried other attempts at making this card work, I have no promises for you, but it only takes two minutes, so it is worth a shot (most people can get it to work, even on a not-so-fresh install).

    The point of this HOWTO is to make it as simple as possible (not to educate people - if you want to know how this works, open the script and read it) for people who have just installed Ubuntu for the first time, so I wrote a script and have provided a set of drivers that worked for me. Not all drivers will work with ndiswrapper, so please use the ones I have provided.

    The script requires no internet connection after it is downloaded...all required files are on the CD you installed Ubuntu with, and the package manager should recognize this.

    Feisty and Gutsy

    If you post for help, please post the log file, which can be found on your Desktop after you run the script.

    You have two options (I'll try and outline them for you):

    1. Use the native bcm43xx driver. This driver is open source and included with the kernel. It can not run at any speed higher then 11mbps, is some what flaky, and supports promiscuous mode. Requires user to be somewhat close to the access point. Is a bit easier to install.
      To use the native bcm43xx driver:
      Download and double click it to install. Reboot. Enjoy wireless. (this should work, but if for some reason it fails, see the troubleshooting)
    2. Use ndiswrapper. ndiswrapper is open source, however the driver is not. It can run at 54mbps, is stable, and does not support promiscuous mode. I have had some trouble with it and hidden networks. Supports a large distance from the access point.

    If you aren't sure what to use and just want wireless, I suggest ndiswrapper (option 2) See section Dapper and Edgy (and Feisty/Gutsy with ndiswrapper) below.

    Dapper and Edgy (and Feisty/Gutsy with ndiswrapper)

    1. Put the CD that you installed Ubuntu with in the CD drive.
    2. Download this file to your Desktop (the Firefox default, so if you haven't changed it, that's where it went/will go).
    3. Open a terminal (click the Applications button, then Accessories, and then Terminal)
    4. Change the current directory to the desktop (copy and paste the following commands exactly into your terminal by right clicking anywhere on the terminal and clicking paste)
      cd ~/Desktop
    5. Extract the compressed file
      tar -xf bcm4318*.tar.gz
    6. Run the script, which will install ndiswrapper on your system, and set it up.
      sudo ./ndiswrapper_setup
    7. Use the internet (you will have to open the System menu at the top of the screen, go to Administration, and then click Networking. Configure the interface eth1 or wlan0, and connect to your wifi network)
    8. If you are an Acer user, you will need to use the acerhk driver.
    9. If it doesn't work, reboot.
    10. If that doesn't work, read the troubleshooting section below.
    11. If you still can't make it work, try reading this post by The Raven, which is so long I can't even fit it in here without doubling the length of the post =D>


    • If the normal Feisty method fails, try the Edgy/Dapper method. It also has support for Feisty using ndiswrapper.
    • Try
      sudo ndiswrapper -a 14e4:4319 bcmwl5
      and then
      sudo rmmod bcm43xx
      sudo rmmod ndiswrapper
      sudo modprobe ndiswrapper
    • If the light doesn't come on, try:
      sudo apt-get install ndiswrapper-utils-1.8 ndiswrapper-utils-1.1 ndiswrapper-utils ndiswrapper-common
    • If you are using 64bit Edgy Eft and the 2.6.17-10-generic, make sure you are NOT using the 2.6.17-10-generic kernel as it doesn't work (after running the script, you will be warned if there is a problem). If you need help finding a different kernel, check here.
    • If you have issues with Network Manager, make sure that all lines in /etc/network/interfaces that have anything except the word (interface) LO in them are commented out (have a # in front of them) or do not exist (the installation script should have removed them)
    • If you are having issues, try running, in this order, one at a time:
      sudo rmmod bcm43xx
      sudo rmmod ndiswrapper
      sudo modprobe ndiswrapper
      sudo ifdown eth1
      sudo ifup eth1
      sudo dhclient
    • If you get the error "The NetworkManager applet could not find some required resources. It cannot contine.", run:
      sudo gtk-update-icon-cache -f /usr/share/icons/hicolor/
    • If you are using Edgy, try enabling the Universe and Multiverse, then run the script again.
    • If, when you turn your computer on, Network Manager asks for your password, and then sits there and twirls, but doesn't connect, and eventually times out, and THEN will connect, try removing wifi radar (or another wireless manager if you have one)
      sudo apt-get remove wifi-radar
      sudo apt-get remove NAME-OF-YOUR-WIFI-MANAGER
    • Try reading this post, which is incredibly long and very helpful
    • If you want to know how to remove it, either (a) read the script and undo what it does, or (b) post a message here and I will write an undo script for you, or (c) reinstall Dapper.
    • Make sure that the card is enabled in the BIOS.
    • If you've got a HP dv8000 series that doesn't work quite right, or even if you don't and have run out of ideas, try


    There are all obsolete (but I'll leave them here in case anyone needs them for any reason):
    32-bit with network manager:
    64-bit with network manager:
    32-bit drivers for Edgy:
    64-bit drivers for Edgy:
    32-bit setup for Edgy:
    64-bit setup for Edgy:

    Posting for help

    If you post for help here, please attach the log file, which will be on your Desktop after you run the script, to your post. Make sure you wrap your log file in
    HTML Code:
    tags, which makes reading the log file much easier.


    EDIT: This was updated on June 20, 2006 to make the size smaller, and include ndiswrapper so that an internet connection is not required. Also, some steps were removed from the installation process.
    EDIT: This was updated on June 21, 2006 to add a 64-bit version (thanks redmoth!) and to make a few minor changes.
    EDIT: This was updated on June 22, 2006 so that now it supports network manager AND WPA encryption (use WPA supplicant) -thanks magomago!
    EDIT: This was updated on June 28, 2006 to add some troubles and answers from the thread, up to page 11. I'm not promising I got everything, but most of it.
    EDIT: This was updated on July 7, 2006 to include a GTK enabled C++ application that will automatically install the drivers WITHOUT use of the terminal. If you run the program from a terminal, additional output will be visible. This requires internet access, but looks really pretty
    EDIT 2: That didn't work out, so I removed it. If you still wanna give it a go (you need gtkmm installed), download the bcm4318.gtk.tar.gz attachment.
    EDIT: This was updated on August 7, 2006 to include a new and improved i386 (NOT AMD64) script that will actually work on the LiveCD now, I believe. Thanks iandefor!
    EDIT: This was updated September 2, 2006 with some awesome new features. The network-manager-gnome setup should now actually work correctly on a fresh install. The script that includes network-manager-gnome will automagically connect to the internet using your nearest wifi hotspot or an ethernet connection if you're plugged in. The 64bit drivers are also updated and should work right now (I can't say if they do, as I don't have a 64bit Ubuntu to test them on)
    EDIT: This was updated September 3, 2006. All versions of the program are now distributed under the GPL.
    EDIT: This was updated September 21, 2006 to include a link to another howto for HP dv8000 series laptops.
    EDIT: This was updated September 30, 2006 to include directions for Edgy.
    EDIT: This was updated October 4, 2006 to include scripts for Edgy.
    EDIT: This was updated October 28, 2006 so that there is only one script, which takes care of all arches and versions.
    EDIT: This was updated March 13, 2007 to add a link to the Feisty installation information. Sorry, no script yet.
    EDIT: This was updated April 20, 2007 to add the script for Feisty support, in case the .deb method fails.
    EDIT: This was updated July 2, 2007 with an updated script (thanks LowMemory!)
    EDIT: This was updated April 18, 2008 with instructions for Hardy.

    Comments and suggestions are appreciated.
    Attached Files Attached Files
    Last edited by compwiz18; May 24th, 2008 at 02:20 PM. Reason: updated for Hardy

Tags for this Thread


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts