I am trying to get graphics power management to work with my Thinkpad t43 running Ubuntu 11.10. The t43 has a Mobility Radeon x300 with 64mb of dedicated vRAM. When I used the Additional Hardware utility to find the proprietary driver for it, it did not find any proprietary drivers. However, I had read on the thinkpad wiki that fglrx did work with the Mobility x300 and I installed the package anyway using synaptic. When I run fglrxinfo, I get:
Code:
X Error of failed request: BadRequest (invalid request code or no such operation)
Major opcode of failed request: 136 (GLX)
Minor opcode of failed request: 19 (X_GLXQueryServerString)
Serial number of failed request: 12
Current serial number in output stream: 12
When I output the Xorg log, I find that it is still using Radeon, the open source driver for my card. Running aticonfig returns an error saying that it could not find a compatible card and exits. Also, when I tried to look up what driver Ubuntu was using in the System Info application, the graphics option says that the driver is unknown.

What do I need to do to get 3d acceleration working with the x300?