Annoyingly, when any kind of application is in full-screen, the text and icons on the panel are always visible (appmenu, indicators, the clock etc).

Even more annoyingly, the mouse regards them as under the full-screen window (where they should be), so the indicator icons and application menus don't respond to clicks.

Is there any way to stop the panel from being displayed on top of everything?

I don't want to hide the panel, just have it properly covered when a full-screen window opens.

Is there any setting for this in ccsm, gconf, or dconf?