11.04, star4

Out of the blue, the configuration I set up following the knowledge76 Star4 guide stopped working for my touchpad. I checked my settings, and I accidentally followed the Bonobo Professional instructions, because my Star4 says it is a Bonobo Performance ("model:bonp4") on the bottom.

Following those instructions, I noticed that they suggest using
#! /bin/bash
gksudo fspc -t -l ~/.fspc/fspc.ini
where the Star4 instructions suggest regular sudo. I made that change, and while my settings don't load when I reboot, the GUI configuration panel opens. This is suboptimal, but at least I don't have ****ing touch-to-click enabled anymore

After I noticed that the instructions for the Bonp4 and the Star4 were different, I tried changing it back. When I do that the GUI doesn't open when I run start-touchpad, but my settings don't load either. And if I open the GUI by running fspc from the terminal, I can't change the configuration, I get an error message when I hit 'apply'.

Ideally, I'd like my settings to load, and to not have the GUI open every time I start up. But I'm also curious why the change from sudo to gksudo would cause this. Don't they do basically the same thing? And if the command
fspc -t -l ~/.fspc/fspc.ini
isn't supposed to open the GUI, why is it? And what could I have changed to break the original settings and bring about this state of affairs? or has there been a recent update that could have changed something?