Results 1 to 10 of 72

Thread: Atheros AR9285/Ubuntu 11.04/Lenovo B575 (Wireless Disabled?)

Threaded View

  1. #1
    Join Date
    Aug 2011
    Location
    New Jersey
    Beans
    9
    Distro
    Ubuntu 11.04 Natty Narwhal

    Atheros AR9285/Ubuntu 11.04/Lenovo B575 (Wireless Disabled?)

    /* SOLVED */

    Hi guys, I recently bought a new laptop (Lenovo B575) for school/work and went to put Ubuntu on it. I run it on my desktop which has a wired connection and I've never had any problems. However I seem to be having a bit of trouble getting the wireless to work at all. Even with "Enable Wireless" checked off in Network Manager and my wifi switch turned on, it is still telling me that my wireless is disabled. From what I've gathered from troubleshooting this, my card (Atheros AR9285) has worked on previous versions of Ubuntu, but doesn't seem to play nice with Natty Narwhal for some reason. I have checked the wireless troubleshooting guide as well as scoured the internet to find a solution but have found nothing that has worked. I will post all recommended information as mentioned in http://ubuntuforums.org/showthread.php?p=6183681.

    1. Make and Model: Lenovo B575

    2. lspci -nn | grep 'Atheros' output:

    mark@ubuntu:~$ lspci -nn | grep 'Atheros'
    03:00.0 Network controller [0280]: Atheros Communications Inc. AR9285 Wireless Network Adapter (PCI-Express) [168c:002b] (rev 01)
    3. ifconfig and iwconfig output:

    mark@ubuntu:~$ ifconfig
    eth0 Link encap:Ethernet HWaddr f0:de:f1:6d:e7:5c
    inet addr:192.168.1.105 Bcast:192.168.1.255 Mask:255.255.255.0
    inet6 addr: fe80::f2de:f1ff:fe6d:e75c/64 Scope:Link
    UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
    RX packets:4996 errors:0 dropped:0 overruns:0 frame:0
    TX packets:3591 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:4687716 (4.6 MB) TX bytes:514442 (514.4 KB)
    Interrupt:42 Base address:0xa000

    lo Link encap:Local Loopback
    inet addr:127.0.0.1 Mask:255.0.0.0
    inet6 addr: ::1/128 Scope:Host
    UP LOOPBACK RUNNING MTU:16436 Metric:1
    RX packets:16 errors:0 dropped:0 overruns:0 frame:0
    TX packets:16 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:0
    RX bytes:960 (960.0 B) TX bytes:960 (960.0 B)

    mark@ubuntu:~$ iwconfig
    lo no wireless extensions.

    eth0 no wireless extensions.

    wlan0 IEEE 802.11bgn ESSID:off/any
    Mode:Managed Access Point: Not-Associated Tx-Power=17 dBm
    Retry long limit:7 RTS thr:off Fragment thr:off
    Power Management:on
    4.lsmod | grep "ath9k" output:

    mark@ubuntu:~$ lsmod | grep "ath9k"
    ath9k 118238 0
    mac80211 294370 1 ath9k
    ath9k_common 13851 1 ath9k
    ath9k_hw 323077 2 ath9k,ath9k_common
    ath 23773 2 ath9k,ath9k_hw
    cfg80211 178528 3 ath9k,mac80211,ath
    5. Will post dmesg on request if necessary.

    6. sudo lshw -C network output (excluding eth0 which works fine):

    *-network DISABLED
    description: Wireless interface
    product: AR9285 Wireless Network Adapter (PCI-Express)
    vendor: Atheros Communications Inc.
    physical id: 0
    bus info: pci@0000:03:00.0
    logical name: wlan0
    version: 01
    serial: d0:df:9a:12:8c:79
    width: 64 bits
    clock: 33MHz
    capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
    configuration: broadcast=yes driver=ath9k driverversion=2.6.38-11-generic firmware=N/A latency=0 link=no multicast=yes wireless=IEEE 802.11bgn
    resources: irq:18 memory:e0100000-e010ffff
    7. iwlist scan output:

    mark@ubuntu:~$ iwlist scan
    lo Interface doesn't support scanning.

    eth0 Interface doesn't support scanning.

    wlan0 Failed to read scan data : Network is down
    8. lsb_release -d output:

    mark@ubuntu:~$ lsb_release -d
    Description: Ubuntu 11.04
    9. uname -mr output:

    mark@ubuntu:~$ uname -mr
    2.6.38-11-generic x86_64
    10. sudo /etc/init.d/networking restart output:

    mark@ubuntu:~$ sudo /etc/init.d/networking restart
    * Running /etc/init.d/networking restart is deprecated because it may not enable again some interfaces
    * Reconfiguring network interfaces... [ OK ]
    mark@ubuntu:~$
    I appreciate any help I can get with this issue. If any more information is needed to help, please ask. Thank you!
    Last edited by mdunphy; September 1st, 2011 at 12:29 PM.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •