Results 1 to 10 of 229

Thread: Acer Aspire One 722 Ubuntu 11.04 fixes

Threaded View

  1. #1
    Join Date
    Jun 2009

    Acer Aspire One 722 Ubuntu 11.04 fixes

    About a week ago, I bought Acer Aspire One 722. After initial installation of Ubuntu 11.04, I had a couple of problems/annoyances, and I managed to solve them. This is a list of fixes that I applied:

    1. Freezing after login (with unplugged network cable). This is caused by wireless driver. Easy fix is to make network boot as a first option in BIOS (hold F2 after reboot). The solution for this was found on:

    2. Better power management. For now, AMD's Catalyst driver doesn't support sleep mode on this netbook (computer freezes on wake-up), but open source Radeon does, and this is why I choosed it. This driver has options for reduced power consumption, but they are not activated by default. To make laptop battery lasts longer, I installed Jupiter. To do this, open terminal and type:
    sudo su
    add-apt-repository ppa:webupd8team/jupiter
    apt-get update
    apt-get install jupiter
    Don't close the terminal yet. Start the program (Alt+F2, type jupiter-run), and it will add itself to list of allowed programs for systray, and also to startup applications. Beacuse Jupiter (version 0.0.50) still doesn't have options for OSS Radeon driver power management, I added them manually (version 0.0.51 has this fix already included, thanks to fuduntu, so if you have this version, there is nothing more to do for step 2). To do this, on the same terminal type:
    mkdir -p /usr/lib/jupiter/vendors/Acer
    cd /usr/lib/jupiter/vendors/Acer
    gedit battery power
    When gedit opens, copy this to battery script:
    echo low > /sys/class/drm/card0/device/power_profile
    and this to power script:
    echo high > /sys/class/drm/card0/device/power_profile
    Save both scripts and close gedit. Then, type this in terminal:
    chmod 755 battery power
    Details about this changes can be found at:

    If you don't want to install Jupiter, but you want better power management, you should look at sbraz's post:

    3. Touchpad rotating together with screen rotating. 722 netbook is very suitable to be used as a ebook reader, simply by rotating it's screen by 90 degrees (it comes natural to hold it as a book). Jupiter has nice options for screen rotating, but there is one slight annoyance: when you select different screen orientation, and rotate netbook accordingly, the touchpad movement remains unchanged, and it becomes difficult to navigate. This is solved with latest patches for xorg's synaptics driver. To get the updated driver, open terminal and type:
    sudo add-apt-repository ppa:aapo-rantalainen/ppa-aaporantalainen
    sudo apt-get update
    sudo apt-get install xserver-xorg-input-synaptics
    After this, computer needs to be restarted. Now, screen rotation is synchronised with correct touchpad movement. Details about this can be found at:

    4. Headphone sensing and internal microphone. In default Ubuntu 11.04 on 722, when you plug your headphones, the sound from speakers isn't turned off and internal microphone isn't working. To solve these issues, download and install (by double-clicking on it):
    This patch is actually for another Acer laptop, but I found that it solves the same problem on 722. There are however, two caveats for this. First, external microphone still isn't working, and second, if internal microphone still isn't working, you'll need to go to Sound preferences/Input and mute and then unmute microphone (to enable internal microphone, in Sound Preferences/Hardware "Internal Audio" must be selected, and "Analog Stereo Duplex" profile. On input tab, "Internal microphone" connector should be selected, and Input volume should be adjusted to about 100%). With this fix, Skype and Google Talk/Video work just fine. Details about this fix can be found at:

    5. CapsLock indicator. 722 doesn't have keyboard LED indicators, which can be quite annoying, especially with CapsLock. To solve this I installed keylock indicator (by T. Scott Barnes). To do this, open terminal, and type:
    sudo add-apt-repository ppa:tsbarnes/indicator-keylock
    sudo apt-get update
    sudo apt-get install indicator-keylock indicator-keylock-ubuntu-mono
    Instead of indicator-keylock-ubuntu-mono, you could use indicator-keylock-humanity or indicator-keylock-elementary (or, you could install them all). After this, open Startup Applications (from System Settings), click on Add, and enter "KeyLock Indicator" for Name and "/usr/bin/indicator-keylock" for Command (without quotes). To start indicator immediately, press Alt+F2 and enter indicator-keylock.

    6. Multitouch gestures. 722 has a multitouch touchpad, and I found two-finger scrolling quite natural to use. You can enable it by going to Mouse/Touchpad setings (in Control Centre). Select Two-finger scrolling, and enable Horizontal scrolling.

    7. Slow Unity with Catalyst drivers. When I tried Catalyst drivers, the Unity was slower than with OSS driver. To solve this issue, install CCSM (Compiz Config Settings Manager, it can be found in default repository), and make these changes:
    In CCSM/Composite: disable Detect Refresh Rate
    In CCSM/OpenGL: disable Sync to Vblanc and set texture filter to fast
    In Catalyst Control Center in display options disable Tear Free
    After returning to OSS driver, I left the first two fixes (I didn't test if they actually make Unity faster, but they don't slow it down). I found about this fix at:

    8. Power regression in Linux kernel. The good people at Phoronix found that Linux since version 2.6.38 on many computers has a 10-30% bigger power consumption than previous versions. They found a couple of reasons for this, but the main one was different handling of ASPM (Active-State Power Management). To solve this issue, you need to edit /etc/default/grub file. To do so, open terminal and type:
    sudo gedit /etc/default/grub
    Now, find the line
    and change it to
    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash pcie_aspm=force"
    Save the file, close gedit and type:
    sudo update-grub
    After that, restart computer. More details about this fix can be found at:

    These are the fixes I did so far. If I found more (or, if I remember something I didn't put here), I will add to this post.

    Enjoy your 722,

    P.S. Thanks all for your comments!

    Still unsolved issues:
    - External microphone doesn't work (for me)
    - Sleep function with proprietary AMD drivers - I tried latest Catalyst driver (11.8 version) and sleep function still doesn't work

    EDIT 1: Added link for #1 and added #8.
    EDIT 2: Added information about Jupiter 0.0.51 and list of unsolved issues (that I know of)
    EDIT 3: Tested Catalyst 11.8, added link in #2 to sbraz's post about power management
    EDIT 4: Corrected error in #2, jupiter-run instead of jupiter after Alt+F2 (thanks thunderriver)
    Last edited by zzarko; September 7th, 2011 at 10:42 AM.

Tags for this Thread


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts