Results 1 to 3 of 3

Thread: [warn] NameVirtualHost *:443 has no VirtualHosts

  1. #1
    Join Date
    Sep 2007
    Location
    Lake Orion, MI
    Beans
    15
    Distro
    Ubuntu 10.04 Lucid Lynx

    [warn] NameVirtualHost *:443 has no VirtualHosts

    After running the upgrade to from 8.04 LTS to 10.04 LTS, I can no longer access the virtualhosts, only the index.html file in the /var/www folder loads. I also get this error twice when apache2 starts:

    [warn] NameVirtualHost *:443 has no VirtualHosts
    [warn] NameVirtualHost *:443 has no VirtualHosts

    What is wrong?! How can this be fixed?

  2. #2
    Join Date
    Jul 2009
    Beans
    571
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: [warn] NameVirtualHost *:443 has no VirtualHosts

    Any solutions to this yet?

    This problem has been bugging me as well, as I'm just learning how to SSL. And this came up.
    It's OK, everything we know will become obsolete at some time.

  3. #3
    Join Date
    Jul 2009
    Beans
    571
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: [warn] NameVirtualHost *:443 has no VirtualHosts

    I found the solution to this: Just follow these threads:

    http://www.tc.umn.edu/~brams006/selfsign_ubuntu.html

    And this:

    http://www.howtoforge.com/forums/showthread.php?t=33015

    Mine specifically, I forgot to link the sites-available/default-ssl to sites-enabled/000-default-ssl

    Good luck!
    It's OK, everything we know will become obsolete at some time.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •