Results 1 to 3 of 3

Thread: Problem updating linux kernel

  1. #1
    Join Date
    Oct 2009

    Problem updating linux kernel

    When I installed the kernel image I got
    Possible missing firmware /lib/firmware/rtl_nic/rtl8105e-1.fw for module r8169
    I can boot/log in fine, but when I try to install video drivers (ATI Catalyst11.6 from AMD site) I get that same error.

    When I try sudo apt-get update, I get:
    W: Failed to fetch  404  Not Found
    W: Failed to fetch  404  Not Found
    E: Some index files failed to download. They have been ignored, or old ones used instead.
    I have Ubuntu 11.04. I started with driver: 2.6.38-8-generic.

    Here are the steps I followed to install the kernel v2.6.39-rc4:

    1. Downloaded files from
    2. using sudo dpkg -i, installed the following in order:
      • linux-headers...all.deb
      • linux-headers..generic..64.deb
      • linux-image....64.deb

    3. Restart

    I originally got the firmware error after installing linux-image....64.deb.

    I already tried fixing it according to this:

    • I added the ppa:chasedouglas/linux-firmware

    But that now just gives me the
     W: Failed to fetch  404  Not Found
    When I apt-get update.

    Anyone know what I broke?

  2. #2
    Join Date
    Sep 2005

    Re: Problem updating linux kernel

    It would appear that the latest kernel doesn't provide the realtek firmware.

    Debian have recognised it is a bug,

    You could manually extract the needed files from the deb package found here

    n.b. You will get a conflict error if you try to install this package as it tries to replace a file which is already installed in the linux-firmware package.

    My guess is that linux-firmware needs updating to include these missing files.

  3. #3
    Join Date
    Jun 2006
    Nux Jam
    Ubuntu Development Release

    Re: Problem updating linux kernel

    you should try with the latest 3.0.3 kernel


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts