(See bottom for Sparknotes.)

I've installed UberStudent (which is based on Ubuntu 10.04 LTS--the boot processes are the same) on my netbook through a USB drive using UNetbootin. I had to do some troubleshooting to get it to install (to the point of actually having to go through the Python source for ubiquity), but I got it working, and it boots to the login screen fine.

The problem is, it gives an "Authentication failure" when I attempt to login, even though I'm using the exact username and password I specified in the install. (I double-checked it and even reinstalled--it wasn't a simple typo.)

So I tried to go into Recovery Mode to drop into a root shell and change/set my password. Now recovery mode won't boot. The main version does. Here's a video I took from a friend's laptop of what happens: http://www.youtube.com/watch?v=WG57rdbHl2A.

I've done some googling and tried some of the solutions people have said worked, but nothing's good for me.

Main Ubuntu install boots fine, but won't accept my username/password. I tried to boot to Recovery Mode, and it goes to a blank screen: http://www.youtube.com/watch?v=WG57rdbHl2A

Asus Eee PC 1215N
nVidia ION graphics card
More details: http://www.newegg.com/Product/Produc...82E16834220806

Does anyone have any ideas on how to fix this, either by getting Recovery Mode to boot successfully OR getting the installer to set my password?