Page 1 of 3 123 LastLast
Results 1 to 10 of 29

Thread: 11.04 Natty wireless issue - Acer - Device not ready

  1. #1
    Join Date
    Dec 2008
    Location
    S.Oz:fromWales via Sol.Is
    Beans
    36

    Angry 11.04 Natty wireless issue - Acer - Device not ready, rfkill soft auto blocked

    Hi - I've tried looking through other posts but haven't found a solution as yet, so sorry to put this one out there...

    I've an Acer TravelMate TM8372T with 802.11 a/b/g/n and have had 10.10 on which worked fine before, but then windows stuffed up, and my IT dept re-imaged it with Win 7 After I reinstalled and upgraded to 11.04 I cannot get wireless on 11.04 (but on Win 7, it works fine!)...

    Initially my wireless light was off.

    According to the drop down networking icon initially it was
    wireless turned off
    but after trying the Fn+F3 button a few times and the wireless button that changed, so it now states
    Wireless Networks device not ready
    although sometimes it changes for a second to
    Connect to hidden network & Create new wireless network
    while pressing the Fn+F3, but changes back too fast to select...


    I have also ticked Enable Wireless in the list too.


    I typed lspci and had this:
    01:00.0 Network controller: Intel Corporation Centrino Advanced-N 6200 (rev 35)
    03:00.0 Ethernet controller: Broadcom Corporation NetXtreme BCM57760 Gigabit Ethernet PCIe (rev 01)

    If I do ifconfig I can see:
    wlan0 Link encap:Ethernet HWaddr 00:27:10:0x:0x:0x
    UP BROADCAST MULTICAST MTU:1500 Metric:1
    RX packets:0 errors:0 dropped:0 overruns:0 frame:0
    TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)
    which I take to mean that I have an device which is recognized.


    I have run Addition Drivers, but it tells me there are no proprietary drivers in use on the system.


    I can get the wireless LED to come on by entering
    sudo ifconfig wlan0 up
    and to go off using
    sudo ifconfig wlan0 down
    but this doesn't help me to connect.


    I have also tried
    sudo ifconfig wlan0 up
    but that didn't seem to do anything.


    I've set up a Wireless Network Connection with a WPA & WPA2 Personal key, which I copied from another Ubuntu machine I have, and I have double checked the key, but I don't think this is relevant as the Network drop down list still has
    Wireless Networks device not ready
    grayed out.


    I think that my card has been found and drivers installed, but is somehow turned off. If anyone can help me I'll be very grateful.

    Thanks,

    Rob.

    UPDATE 14/5/2011.

    Still not working, but I've found that if you do a sudo rfkill list all, then it shows:

    0: acer-wireless: Wireless LAN
    Soft blocked: yes
    Hard blocked: no

    If I use the Fn+F3 button, while watching the output from "rfkill event" I see it change to:

    13053645xx.xxxxxx: idx 0 type 1 op 2 soft 0 hard 0
    13053645xx.xxxxxx: idx 2 type 1 op 2 soft 0 hard 0
    13053645xx.xxxxxx: idx 2 type 1 op 2 soft 0 hard 0
    13053645xx.xxxxxx: idx 0 type 1 op 2 soft 1 hard 0

    (Do this by opening two different Terminal screens, and run "sudo rfkill event" in one, and then you can do other rfkill commands in the other one, while watching the output in the first screen.)

    It's as if it is being turned on, but then something is automatically re-soft blocking almost immediately I unblock it, by either using the "Fn+F3" or "sudo rfkill unblock all".


    Please help as it's a bit embarrassing, I'm trying to get a class of gifted kids into linux on desktops and their teacher can't even connect to the wireless!


    UPDATE 15/5/2011.

    Just read this post: "Wireless disabled by hardware switch" bug? - Natty and have got this output for "dmesg | grep iwl":

    rob@robtintech:~$ dmesg | grep iwl
    [ 15.925638] iwlagn: Intel(R) Wireless WiFi Link AGN driver for Linux, in-tree:
    [ 15.925643] iwlagn: Copyright(c) 2003-2010 Intel Corporation
    [ 15.925717] iwlagn 0000:01:00.0: PCI INT A -> GSI 16 (level, low) -> IRQ 16
    [ 15.925728] iwlagn 0000:01:00.0: setting latency timer to 64
    [ 15.925766] iwlagn 0000:01:00.0: Detected Intel(R) Centrino(R) Advanced-N 6200 AGN, REV=0x74
    [ 15.942097] iwlagn 0000:01:00.0: device EEPROM VER=0x436, CALIB=0x6
    [ 15.942102] iwlagn 0000:01:00.0: Device SKU: 0Xb
    [ 15.943197] iwlagn 0000:01:00.0: Tunable channels: 13 802.11bg, 24 802.11a channels
    [ 15.943283] iwlagn 0000:01:00.0: irq 41 for MSI/MSI-X
    [ 16.068803] iwlagn 0000:01:00.0: loaded firmware version 9.221.4.1 build 25532
    [ 16.083562] ieee80211 phy0: Selected rate control algorithm 'iwl-agn-rs'
    [ 199.600594] iwlagn 0000:01:00.0: RF_KILL bit toggled to enable radio.
    [ 200.095805] iwlagn 0000:01:00.0: Failing on timeout while stopping DMA channel 1 [0xa5a5a5a2]
    [ 200.101538] iwlagn 0000:01:00.0: Failing on timeout while stopping DMA channel 3 [0xa5a5a5a2]
    [ 200.107182] iwlagn 0000:01:00.0: Failing on timeout while stopping DMA channel 4 [0xa5a5a5a2]
    [ 200.112915] iwlagn 0000:01:00.0: Failing on timeout while stopping DMA channel 6 [0xa5a5a5a2]
    [ 245.597524] iwlagn 0000:01:00.0: RF_KILL bit toggled to disable radio.
    [ 247.674860] iwlagn 0000:01:00.0: RF_KILL bit toggled to enable radio.
    ...and this for: "lsmod | grep -e acer -e wmi"

    rob@robtintech:~$ lsmod | grep -e acer -e wmi
    snd_rawmidi 25269 1 snd_seq_midi
    acer_wmi 23123 0
    sparse_keymap 13666 1 acer_wmi
    snd_seq_device 14110 3 snd_seq_midi,snd_rawmidi,snd_seq
    snd 55295 13 snd_hda_codec_conexant,snd_hda_intel,snd_hda_codec ,snd_hwdep,snd_pcm,snd_rawmidi,snd_seq,snd_timer,s nd_seq_device
    Still think something is turning it off all the time...

    Any suggestions gratefully considered...
    Last edited by abisdad; May 14th, 2011 at 06:08 PM.

  2. #2
    Join Date
    Aug 2005
    Location
    South Carolina, USA
    Beans
    25,479
    Distro
    Ubuntu 20.04 Focal Fossa

    Re: 11.04 Natty wireless issue - Acer - Device not ready

    Please let us see:
    Code:
    sudo rmmod -f acer-wmi
    sudo rfkill unblock all
    rfkill list all
    Does your wireless work now? We can amend two files and make it permanent.
    "Oh, Ubuntu, you are my favorite Linux-based operating system" --Dr. Sheldon Cooper, Ph.D., Sc.D.

  3. #3
    Join Date
    Dec 2008
    Location
    S.Oz:fromWales via Sol.Is
    Beans
    36

    Talking Re: 11.04 Natty wireless issue - Acer - Device not ready

    Chili555 - you're magic! I thought it was something easy! I'm now using the link, instead of copying stuff to post by USB!

    rob@robtintech:~$ sudo rfkill unblock all
    rob@robtintech:~$ sudo rfkill list all
    2: phy0: Wireless LAN
    Soft blocked: no
    Hard blocked: no
    So how do I make this permanent? (and what did you just get me to do?)

    Also will this affect my wired LAN when I get back to work?

    Thanks again!

    Rob.
    Last edited by abisdad; May 14th, 2011 at 05:57 PM.

  4. #4
    Join Date
    May 2011
    Beans
    1

    Re: 11.04 Natty wireless issue - Acer - Device not ready

    Wow.... Nice Tips. These tips are ver useful. Thanks for sharing this informative information. Please keep sharing more and more information.

    Thanks
    Have a nice time ahead.


    krogen krogragg dating festa

  5. #5
    Join Date
    Aug 2005
    Location
    South Carolina, USA
    Beans
    25,479
    Distro
    Ubuntu 20.04 Focal Fossa

    Re: 11.04 Natty wireless issue - Acer - Device not ready

    So how do I make this permanent? (and what did you just get me to do?)
    Code:
    sudo su
    echo "blacklist acer-wmi" >> /etc/modprobe.d/blacklist.conf
    gedit /etc/rc.local
    Add one line above Exit 0
    Code:
    rfkill unblock all
    Proofread, save and close gedit.
    Code:
    exit
    I got you to remove the mis-behaving acer-wmi module that is supposed to recognize the press of the wireless key and translate its meaning to the kernel. It sometimes doesn't work so well, so we simply remove it. I doubt it will have any effect on wired ethernet.
    "Oh, Ubuntu, you are my favorite Linux-based operating system" --Dr. Sheldon Cooper, Ph.D., Sc.D.

  6. #6
    Join Date
    Dec 2008
    Location
    S.Oz:fromWales via Sol.Is
    Beans
    36

    Exclamation Re: 11.04 Natty wireless issue - Acer - Device not ready

    Hi Chili555, did that:

    blacklist.conf:

    # Added with typo by Rob 15/5/2011 to fix wireless as per chili555

    backlist acer-wmi
    ******* N.B. I've edited this the next morning to highlight typo in RED - moral = got to bed earlier... ********

    and in rc.local

    # Added by Rob 15/5/2011 to fix wireless as per chili555
    rfkill unblock all
    then rebooted, but still didn't work until I did:
    sudo rmmod -f acer-wmi
    sudo rfkill unblock all

    Sorry, but any other ideas how to make it permanent?

    Thanks,

    Rob - being dragged to bed by grumpy, loving wife - it's 03.15am! Check again tomorrow...
    Last edited by abisdad; May 15th, 2011 at 04:35 AM. Reason: To highlight my STUPID typo!

  7. #7
    Join Date
    Aug 2005
    Location
    South Carolina, USA
    Beans
    25,479
    Distro
    Ubuntu 20.04 Focal Fossa

    Re: 11.04 Natty wireless issue - Acer - Device not ready

    but any other ideas how to make it permanent?
    Just one:
    # Added by Rob 15/5/2011 to fix wireless as per chili555
    backlist acer-wmi
    Code:
    # Added by Rob 15/5/2011 to fix wireless as per chili555
    blacklist acer-wmi
    "Oh, Ubuntu, you are my favorite Linux-based operating system" --Dr. Sheldon Cooper, Ph.D., Sc.D.

  8. #8
    Join Date
    Dec 2008
    Location
    S.Oz:fromWales via Sol.Is
    Beans
    36

    Thumbs up Re: 11.04 Natty wireless issue - Acer - Device not ready

    Chili555 you're a ,



    Thank you soooooooooooo much!

    That is fantastic, and now works a dream - once I fixed the typo!

    Rob.

  9. #9
    Join Date
    Jun 2006
    Location
    Norway
    Beans
    2
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: 11.04 Natty wireless issue - Acer - Device not ready

    Thanks, great!!

    this also works for Lenovo Ideapad S12 (atom)

  10. #10
    Join Date
    Jun 2011
    Beans
    6

    Re: 11.04 Natty wireless issue - Acer - Device not ready

    I had a similar problem: Whenever I did "rfkill unblock all", my wireless would go from
    Soft blocked: Yes
    Hard blocked: No

    to

    Soft blocked: No
    Hard blocked: Yes

    Tantalizing, isn't it? In the end, I created the following script as a (barely acceptable) solution:

    sudo rmmod -f ath5k
    sudo rfkill unblock all
    sudo odprobe ath5k

    I hope this script helps someone. In the time being, if anybody knows how to make this permanent, that will be much appreciated.

    I am using a Natty Narwhal, (Ubuntu 11.04) running on Fujitsu Siemens Amilo PA3515 with an Atheros AR5001 wireless module.

    Hope this helps,
    Shoka

Page 1 of 3 123 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •