Results 1 to 5 of 5

Thread: No USB devices :(

  1. #1
    Join Date
    Jan 2010
    Location
    Redruth, Cornwall, UK
    Beans
    191
    Distro
    Ubuntu 10.04 Lucid Lynx

    Angry No USB devices :(

    Logged in today as usual on my 10.10 machine, and had to download a WLAN driver for a friend, and move it to her laptop.
    After plugging in a USB flash drive, my card reader AND my mobile phone and not having any luck I realized something was wrong

    I'm receiving this message from dmesg whenever I insert a USB device


    Code:
    [  162.836021] hub 2-0:1.0: unable to enumerate USB device on port 1
    [  437.500015] usb 2-1: new full speed USB device using ohci_hcd and address 16
    [  437.684016] usb 2-1: device descriptor read/64, error -62
    [  437.972015] usb 2-1: device descriptor read/64, error -62
    [  438.253014] usb 2-1: new full speed USB device using ohci_hcd and address 17
    [  438.436013] usb 2-1: device descriptor read/64, error -62
    [  438.725016] usb 2-1: device descriptor read/64, error -62
    [  439.004021] usb 2-1: new full speed USB device using ohci_hcd and address 18
    [  439.413015] usb 2-1: device not accepting address 18, error -62
    [  439.588025] usb 2-1: new full speed USB device using ohci_hcd and address 19
    [  439.996022] usb 2-1: device not accepting address 19, error -62
    [  439.996032] hub 2-0:1.0: unable to enumerate USB device on port 1
    Kernel V.

    Code:
    Linux matthew-desktop 2.6.35-28-generic #50-Ubuntu SMP Fri Mar 18 19:00:26 UTC 2011 i686 GNU/Linux
    Does anybody have any idea what's going on? Any help greatly appreciated have tried many threads from Google with no luck
    Get out of my way.


  2. #2
    Join Date
    Mar 2011
    Location
    U.K.
    Beans
    Hidden!
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: No USB devices :(

    is this relevant ...

    http://ubuntuforums.org/showthread.php?t=898939

    but it might be "rmmod ohci_hcd" in your case
    Last edited by dragonfly41; April 17th, 2011 at 11:08 PM. Reason: ohci vs. ehci

  3. #3
    Join Date
    Jan 2010
    Location
    Redruth, Cornwall, UK
    Beans
    191
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: No USB devices :(

    Code:
    ERROR: Module ehci_hcd does not exist in /proc/modules
    ERROR: Module
    Code:
    ohci_hcd does not exist in /proc/modules

    However thanks for your post
    Get out of my way.


  4. #4
    Join Date
    Jan 2010
    Location
    Redruth, Cornwall, UK
    Beans
    191
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: No USB devices :(

    I'm not sure what's going on with this,

    I just ran both the commands above ^^ which resulted in errors. Plugged in my Mobile Phone again and now I'm getting this

    Code:
    [  439.996032] hub 2-0:1.0: unable to enumerate USB device on port 1
    [ 4186.654937] process `skype' is using obsolete setsockopt SO_BSDCOMPAT
    [ 5065.640022] usb 2-1: new full speed USB device using ohci_hcd and address 20
    [ 5065.868718] scsi4 : usb-storage 2-1:1.0
    [ 5066.876820] scsi 4:0:0:0: Direct-Access     SonyEric  Mobile Storage  0002 PQ
    Phone is working again
    Get out of my way.


  5. #5
    Join Date
    Mar 2011
    Location
    U.K.
    Beans
    Hidden!
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: No USB devices :(

    command lsmod might give some clues as to what is going on ..

    http://www.neowin.net/forum/topic/55...e/page__st__15

    but at least your mobile is working again.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •