Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: gnome-panel doesn't start on login, but gconf settings look correct

  1. #1
    Join Date
    Oct 2007
    Beans
    92
    Distro
    Ubuntu 10.04 Lucid Lynx

    Question gnome-panel doesn't start on login, but gconf settings look correct

    Hello,

    I installed avant-window-navigator and followed these instructions to remove gnome-panel from startup:

    http://wiki.awn-project.org/FAQ#How_...OME_session.3F

    However I have since uninstalled AWN and now cannot get gnome-panel to load at startup.

    I think I have put my settings back where they should be -- looking at them in gconf-editor:

    1. desktop > gnome > session, the required_components_list is [windowmanager,filemanager,panel]

    2. desktop > gnome > session > required_components_list, the panel value is "gnome-panel"

    Yet gnome-panel does not load at startup. Any ideas why?

    Clarification: I can get gnome-panel to load by listing it under Startup Applications, but I am curious why it won't load via the gconf settings.

    Thanks in advance for your thoughts/help!

  2. #2
    Join Date
    Aug 2008
    Location
    Jawja
    Beans
    2,486
    Distro
    Ubuntu 13.04 Raring Ringtail

    Re: gnome-panel doesn't start on login, but gconf settings look correct

    Press ALT-F2 (to open a terminal) and type gnome panel.

  3. #3
    Join Date
    Oct 2007
    Beans
    92
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: gnome-panel doesn't start on login, but gconf settings look correct

    Thank you but the problem is not getting gnome-panel to start at all - I have it in my Startup Applications - but rather understanding why the gconf settings don't appear to be making it start.

  4. #4
    Join Date
    Feb 2010
    Location
    Hull
    Beans
    359

    Re: gnome-panel doesn't start on login, but gconf settings look correct

    What steps did you use to stop it from starting in the first place?

    EDIT: I just noticed the link at top, It sounds like you did everything right.
    Last edited by Mr_VeRiTy; September 5th, 2010 at 02:06 PM. Reason: Made a mistake

  5. #5
    Join Date
    Jan 2006
    Location
    Waterloo, ON, Canada
    Beans
    214
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: gnome-panel doesn't start on login, but gconf settings look correct

    Any luck? I have the same situation.
    (although in my case, I still have AWN installed, but I found a trick to "load gnome-panel" and hide it, so that I can still use ALT+F2.)

    Just need to get gnome-panel to load again automatically.
    ~Fermmy

  6. #6
    Join Date
    Oct 2008
    Beans
    3,509

    Re: gnome-panel doesn't start on login, but gconf settings look correct

    I think the original posters problem was he had
    [windowmanager,filemanager,panel]
    in the wrong order, as I restarted with that order and gnome-panel failed to load.
    The default order is [windowmanager,panel,filemanager]


    To revert back to the default order
    Code:
    gconf-editor /desktop/gnome/session/required_components_list
    and right click on the required_components_list entry and choose Unset Key.
    Last edited by stinkeye; February 24th, 2011 at 07:45 AM.

  7. #7
    Join Date
    Dec 2009
    Beans
    155
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: gnome-panel doesn't start on login, but gconf settings look correct

    You can go for resetting your gnome settings
    open terminal and type this

    Code:
    rm -rf .gnome .gnome2 .gconf .gconfd .metacity
    Last edited by ankit singh; February 24th, 2011 at 08:11 AM.

  8. #8
    Join Date
    Jan 2006
    Location
    Waterloo, ON, Canada
    Beans
    214
    Distro
    Ubuntu 12.04 Precise Pangolin

    Wink Re: gnome-panel doesn't start on login, but gconf settings look correct

    This was the step I was missing:
    2. desktop > gnome > session > required_components_list, the panel value is "gnome-panel"

    The value for me was "empty".
    ~Fermmy

  9. #9
    Join Date
    Oct 2008
    Beans
    3,509

    Re: gnome-panel doesn't start on login, but gconf settings look correct

    Quote Originally Posted by fermulator View Post
    This was the step I was missing:
    2. desktop > gnome > session > required_components_list, the panel value is "gnome-panel"

    The value for me was "empty".
    Yep ,but I think you may mean the key
    Code:
    gconf-editor /desktop/gnome/session/required_components/panel

  10. #10
    Join Date
    Jan 2006
    Location
    Waterloo, ON, Canada
    Beans
    214
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: gnome-panel doesn't start on login, but gconf settings look correct

    Quote Originally Posted by stinkeye View Post
    Yep ,but I think you may mean the key
    Code:
    gconf-editor /desktop/gnome/session/required_components/panel
    -- yes -- good catch
    ~Fermmy

Page 1 of 2 12 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •