Mythbuntu 10.10 (32bit)
xfce 4.6.2

I've been trying to get this Samsung ML-1740 printer to work which is connected via USB.

My goal is to print a pdf file.

I've installed CUPS v1.4.4 and SANE. No errors.
Using Cups in browser: http://localhost:631/admin works fine.
1. CUPS sees Samsung ML-1740 and identifies it.
2. ML-1740 not in Samsung list nor is (SPL II) so I tried ML-1650, 1250, 1750 (gunshot approach). Nothing worked - no printing of pfd.
3.installed Adobe Reader 9.4.1 for linux via user and then uninstalled it and installed it under root. Didn't change anything. No joy.
4. installed xpdf as root. But it needed lpr.
5. installed lpr as root. no joy
6. installed splix as root. Now Samsung ML-1740, ML-1710 appear as choices in CUPS. still no joy.
7. downloaded linux driver from Samsung and installed it as root. (This driver requires CUPS and SANE.) Choices for Samsung ML-1740 (SPL II) appear. no joy.
8. changed permissions on: chown root:root ..../cups/filter/rastertosamsungspl and all files from Samsung driver install. no joy


I give up. What's the secret to getting this printer to work?