This solution is not working for me. it worked in the past but i just did a fresh reinstall , and i have no sound. when I run this command this time i get the following

howard@howard-laptop:~$ sudo add-apt-repository ppa:ubuntu-audio-dev/ppa
Executing: gpg --ignore-time-conflict --no-options --no-default-keyring --secret-keyring /etc/apt/secring.gpg --trustdb-name /etc/apt/trustdb.gpg --keyring /etc/apt/trusted.gpg --primary-keyring /etc/apt/trusted.gpg --keyserver --recv 4E9F485BF943EF0EABA10B5BD225991A72B194E5
gpg: requesting key 72B194E5 from hkp server
gpg: key 72B194E5: "Launchpad Ubuntu Audio Dev team PPA" not changed
gpg: Total number processed: 1
gpg: unchanged: 1
howard@howard-laptop:~$ sudo apt-get update
Hit lucid Release.gpg
Ign lucid/main Translation-en_US
Ign lucid/restricted Translation-en_US
Ign lucid/universe Translation-en_US
Ign lucid/multiverse Translation-en_US
Hit lucid-updates Release.gpg
Ign lucid-updates/main Translation-en_US
Ign lucid-updates/restricted Translation-en_US
Ign lucid-updates/universe Translation-en_US
Ign lucid-updates/multiverse Translation-en_US
Hit lucid-security Release.gpg
Ign lucid-security/main Translation-en_US
Ign lucid-security/restricted Translation-en_US
Ign lucid-security/universe Translation-en_US
Ign lucid-security/multiverse Translation-en_US
Hit lucid-proposed Release.gpg
Ign lucid-proposed/restricted Translation-en_US
Ign lucid-proposed/main Translation-en_US
Ign lucid-proposed/multiverse Translation-en_US
Ign lucid-proposed/universe Translation-en_US
Hit lucid-backports Release.gpg
Ign lucid-backports/restricted Translation-en_US
Ign lucid-backports/main Translation-en_US
Ign lucid-backports/multiverse Translation-en_US
Ign lucid-backports/universe Translation-en_US
Hit lucid Release
Hit lucid-updates Release
Hit lucid-security Release
Hit lucid-proposed Release
Hit lucid-backports Release
Hit lucid/main Packages
Hit lucid/restricted Packages
Hit lucid/main Sources
Hit lucid/restricted Sources
Hit lucid/universe Packages
Hit lucid/universe Sources
Hit lucid/multiverse Packages
Hit lucid/multiverse Sources
Hit lucid-updates/main Packages
Get:1 lucid Release.gpg [316B]
Ign lucid/main Translation-en_US
Hit lucid-updates/restricted Packages
Hit lucid-updates/main Sources
Hit lucid-updates/restricted Sources
Hit lucid-updates/universe Packages
Hit lucid-updates/universe Sources
Hit lucid Release
Hit lucid-updates/multiverse Packages
Hit lucid-updates/multiverse Sources
Hit lucid-security/main Packages
Hit lucid-security/restricted Packages
Hit lucid/main Packages
Hit lucid-security/main Sources
Hit lucid-security/restricted Sources
Hit lucid-security/universe Packages
Hit lucid-security/universe Sources
Hit lucid-security/multiverse Packages
Hit lucid-security/multiverse Sources
Hit lucid-proposed/restricted Packages
Hit lucid-proposed/main Packages
Hit lucid-proposed/multiverse Packages
Hit lucid-proposed/universe Packages
Hit lucid-backports/restricted Packages
Hit lucid-backports/main Packages
Hit lucid-backports/multiverse Packages
Hit lucid-backports/universe Packages
Fetched 316B in 5s (56B/s)
Reading package lists... Done
howard@howard-laptop:~$ sudo apt-get install linux-alsa-driver-modules-$(uname -r)
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Couldn't find package linux-alsa-driver-modules-2.6.32-27-generic