Results 1 to 10 of 33

Thread: USB CDROM/DVD Device Problems on Ubuntu 10.10

Threaded View

  1. #1
    Join Date
    Nov 2010

    Exclamation USB CDROM/DVD Device Problems on Ubuntu 10.10

    Ubuntu 10.10 seems to have troubles with cdroms...I used Ubuntu 8.04 lts and 10.04 lts with no cdrom issues.
    10.10 does not show my CDROM/DVD USB device in 'Places' and I cannot get it's UUID number via ROOT terminal , yet I did Remastersys backup of entire system, opened the Remastersys folder, right clicked the custom.iso file and burnt it using Brasero, which proves it is working on 10.10 but just not showing an icon. Inserting media of any kind does not open the Nautilus folder, yet other USB devices show immediately (USB sticks and USB harddrive appear instantly).

    The CDROM/DVD USb device works in Windows on a different machine and I also attached a USB harddrive with Windows XP to my netbook which 10.10 is installed on, and the USB CDROM/DVD device shows up fine.
    I tried mounting the device in Ubuntu 10.10, but I'm not that great at understanding commands, and the hundreds of different commands other people tried across the web don't work.

    When I type 'dmesg' the USB CDROM shows up as this (is there an I/O error preventing the USB cdrom drive from displaying???):-

    [ 8284.535666] scsi 9:0:0:0: CD-ROM HL-DT-ST DVDRAM GSA-4084N KQ09 PQ: 0 ANSI: 0
    [ 8285.098044] sr0: scsi3-mmc drive: 24x/24x writer dvd-ram cd/rw xa/form2 cdda tray
    [ 8285.098770] sr 9:0:0:0: Attached scsi CD-ROM sr0
    [ 8285.099262] sr 9:0:0:0: Attached scsi generic sg3 type 5
    [ 9001.878411] usb 1-8: USB disconnect, address 10
    [ 9001.957325] JBD2: I/O error detected when updating journal superblock for sdc1-8.

    Also typing this below showed my device:-
    'ls /dev/disk/by-id -lah'
    lrwxrwxrwx 1 root root 9 2010-11-10 09:42 usb-HL-DT-ST_DVDRAM_GSA-4084N-0:0 -> ../../sr0

    I also typed 'lsusb' and my device showed up on line 6 as 'Genesys Logic, Inc . USB 2.0 IDE Adapter'

    Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
    Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
    Bus 003 Device 002: ID 0168:1998
    Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
    Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
    Bus 001 Device 009: ID 05e3:0701 Genesys Logic, Inc. USB 2.0 IDE Adapter
    Bus 001 Device 004: ID 0bda:0158 Realtek Semiconductor Corp. USB 2.0 multicard reader
    Bus 001 Device 003: ID 174f:1403 Syntek Integrated Webcam
    Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

    but typing this only displayed my internal HDD UUID number on line 4:-
    'ls /dev/disk/by-uuid -lah'

    drwxr-xr-x 2 root root 80 2010-11-10 09:15 .
    drwxr-xr-x 5 root root 100 2010-11-10 09:15 ..
    lrwxrwxrwx 1 root root 10 2010-11-10 09:15 420CDBE80CDBD54F -> ../../sda1
    lrwxrwxrwx 1 root root 10 2010-11-10 09:15 4c593da0-46c2-4dff-b389-a443d87792e5 -> ../../sda2

    My USB CDROM/DVD device installed Ubuntu 10.10 just perfect, but then it disappeared some time without me noticing. Reinstallation does not help, the device still won't appear...It doesn't show up in fstab or mtab.
    This has only been an issue since I installed 10.10 netbook edition. I am currently using GNOME because it uses less CPU power and is more configurable.

    What Ubuntu 10.10 needs is a CDROM detection and installation software a .deb file, so it can be downloaded, installed and opened like a normal program, and would be able to detect a CDROM or DVD attached, and create it within fstab and other files requiring the info...
    If Windows has been able to detect CDROM's since the 1990's I can't see why Ubuntu suddenly has problems..
    People shouldn't have to be subjected to a crash course in programming to add basic standard devices.

    thanks for reading my whinge.
    Last edited by SebMack; November 10th, 2010 at 12:48 PM.

Tags for this Thread


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts