Results 1 to 3 of 3

Thread: GDM loop at login

  1. #1
    Join Date
    Feb 2009

    [Solved] GDM loop at login

    Hey folks!


    I have a kinda strange problem... Just installed 10.10 a few days ago, got my FORTRAN compilers setup and everything running smooth.

    However, at one session i hit the "Suspend" button instead of the "Restart", and the computer went to a black screen, blinking cursor and nothing happened. I suspect it's because I don't have a swap drive, but I had to hit the powerswitch.

    When I rebooted into Ubuntu again I was greeted with a login screen (it's called GDM, right?) even though I have activated automatic login. Everytime I enter my password and username the screen blink, and return to the GDM login screen.

    Attempted solutions:

    Hitting Alt+CTRL+F# gives me a console, but I cant seem to do anything useful there (i.e. does not recognize sudo), but booting into recovery mode gave me access to a root terminal.

    First Attempt

    I have tried to remove and reinstall GDM as suggested in this post http://ubuntu-virginia.ubuntuforums....4&postcount=10

    apt-get remove GDM
    apt-get install GDM
    apt-get install gnome-session

    but with no succes.

    Second Attempt

    Tried to use "purge" instead of "remove" (not quite sure what the difference is, though)

    stop gdm
    apt-get purge gdm
    apt-get install gdm

    again no change.

    Third Attempt

    According to http://ubuntu-virginia.ubuntuforums....9&postcount=11 I could install WDM instead.

    stop gdm
    apt-get purge gdm
    apt-get install wdm

    This gave me semi succes. I got a new login program (WDM) and it actually allowed me to login.

    However, I have modified my bashrc file and used some other settings (I have to ssh a firewall in order to get internet), and it seems like WDM does not load any of my settings, so if possible I would very much just et GDM working instead

    So what now...

    Well this is as far as I've gotten. Any suggestions?

    Thanks in advance!
    Last edited by HappyJaZZ; October 22nd, 2010 at 02:04 PM.

  2. #2
    Join Date
    Feb 2009

    Re: GDM loop at login


  3. #3
    Join Date
    Feb 2009

    Re: GDM loop at login

    I found the problem!

    I edited my /etc/environment file, since I thought it would be able to source the environment for my intel fortran compiler. However, it seemed like that didn't work, and instead made the xserver crash (or something like that).

    Restoring /etc/environment to its previous state solved everything!


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts