Results 1 to 3 of 3

Thread: My wireless adapter isn't cooperating...

Hybrid View

  1. #1
    Join Date
    Feb 2008

    My wireless adapter isn't cooperating...

    Hi folks

    I just installed Ubuntu 8.04 after previously having 7.10 (did a clean install rather than an upgrade)

    Under 7.10, my wireless adapter worked perfectly. Now it seems somehow deactivated.

    Here's the result of a ' lshw -C network'

    WARNING: you should run this program as super-user.
           description: Ethernet interface
           product: RTL8101E PCI Express Fast Ethernet controller
           vendor: Realtek Semiconductor Co., Ltd.
           physical id: 0
           bus info: pci@0000:0e:00.0
           logical name: eth0
           version: 01
           serial: 00:1b:38:16:90:30
           width: 64 bits
           clock: 33MHz
           capabilities: bus_master cap_list ethernet physical
           configuration: broadcast=yes driver=r8169 driverversion=2.2LK ip= latency=0 module=r8169 multicast=yes
      *-network UNCLAIMED
           description: Ethernet controller
           product: AR242x 802.11abg Wireless PCI Express Adapter
           vendor: Atheros Communications Inc.
           physical id: 0
           bus info: pci@0000:14:00.0
           version: 01
           width: 64 bits
           clock: 33MHz
           capabilities: cap_list
           configuration: latency=0
    Note that the wifi doesn't have a logical name. Nor is any sort of wireless connection acknowledged in my network settings. A driver for it is listed in my Hardware Drivers bit, though.

    Could this be because I had the adapter powered off when I installed the OS? What can I do?


    Last edited by itsallcrap; May 3rd, 2008 at 06:15 PM. Reason: corrected typo

  2. #2
    Join Date
    Feb 2007
    Seville, Spain
    Kubuntu 8.04 Hardy Heron

    Re: My wireless adapter isn't cooperating...

    Is the driver that shows in the restricted drivers manager enabled? If it isn't, enable it and it will install the required firmware (provided you connect it to internet using an ethernet cable or other means, of course).

  3. #3
    Join Date
    Feb 2008

    Re: My wireless adapter isn't cooperating...

    Yes, it was enabled and still not having it, but happily I managed to solve the issue with ndiswrapper and a Windows wireless driver.

    To anybody else having this problem, I used this guide:

    For an extremely step-by-step kind of guide, it seems curious that this neglects to mention where you're actually supposed to get the ndis tarball from. Don't even bother trying to find it, folks - Synaptic can do it for you.

    You can mark this one solved, admin types.

    Thanks for your input luisromangz


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts