Results 1 to 10 of 12

Thread: Ubuntu 12.04 Server - No network connection even though web server fully works.

Hybrid View

  1. #1
    Join Date
    Mar 2006
    Beans
    18

    Exclamation Ubuntu 12.04 Server - No network connection even though web server fully works.

    Hello all,

    I am very troubled and I am unable to figure out why my server is unable to connect to the Internet even though my Bind9 and Apache are up and running without any issues. When I try to ping google.com I get the "unknown host google.com" error but when I ping my FQDN which is sammojohn.com it responds without any errors.
    I will attach some of my conf files and hopefully you guys can locate a mistake, which I can't.
    Before, I need to clarify that the server is using DHCP and my router has assigned a static IP to it. It's an AT&T router and it doesn't like it when a machine is using static.

    /etc/networking/interfaces
    Code:
    # The loopback network interface
    auto lo
    iface lo inet loopback
    
    # The primary network interface
    auto eth0
    iface eth0 inet dhcp
    /etc/hosts/ (igemonas is my hostname)
    Code:
    127.0.0.1	localhost.localdomain          localhost
    108.92.196.86   igemonas.sammojohn.com     igemonas
    
    # The following lines are desirable for IPv6 capable hosts
    ::1     ip6-localhost ip6-loopback
    fe00::0 ip6-localnet
    ff00::0 ip6-mcastprefix
    ff02::1 ip6-allnodes
    ff02::2 ip6-allrouters
    Any ideas trust me will help and I appreciate anyone taking the time into helping me out.
    Please let me know if you need anything more.

    Thanks and best regards,
    Sam

  2. #2
    Join Date
    Apr 2012
    Beans
    6,874

    Re: Ubuntu 12.04 Server - No network connection even though web server fully works.

    can you ping remote hosts by IP?

    how is the box getting name services - what does /etc/resolv.conf say? you either need a dns-nameservers line in your interfaces file or a working resolvconf I think

  3. #3
    Join Date
    Mar 2006
    Beans
    18

    Re: Ubuntu 12.04 Server - No network connection even though web server fully works.

    Yes I can ping to remote hosts by IP. For instance from my desktop I pinged google.com and I saw the IP was 173.194.46.14 so from my server I pinged that IP and below is the result
    Code:
    root@igemonas:/etc/bind# ping 173.194.46.14
    PING 173.194.46.14 (173.194.46.14) 56(84) bytes of data.
    64 bytes from 173.194.46.14: icmp_req=1 ttl=52 time=26.8 ms
    64 bytes from 173.194.46.14: icmp_req=2 ttl=52 time=27.1 ms
    64 bytes from 173.194.46.14: icmp_req=3 ttl=52 time=31.2 ms
    ^C
    --- 173.194.46.14 ping statistics ---
    3 packets transmitted, 3 received, 0% packet loss, time 2003ms
    rtt min/avg/max/mdev = 26.838/28.401/31.252/2.019 ms
    and my resolv.conf file is as follows
    Code:
    # Dynamic resolv.conf(5) file for glibc resolver(3) generated by resolvconf(8)
    #     DO NOT EDIT THIS FILE BY HAND -- YOUR CHANGES WILL BE OVERWRITTEN
    nameserver 127.0.0.1
    search gateway.2wire.net
    I have noticed too that I am getting some weird errors due to RNDC which I just noticed, and I am not sure if that is causing the error

    Code:
    root@igemonas:/etc/bind# service bind9 restart
     * Stopping domain name service... bind9                                                                                                                       WARNING: key file (/etc/bind/rndc.key) exists, but using default configuration file (/etc/bind/rndc.conf)
    rndc: no server specified and no default
    waiting for pid 2903 to die
                                                                                                                                                            [ OK ]
     * Starting domain name service... bind9

  4. #4
    Join Date
    Apr 2012
    Beans
    6,874

    Re: Ubuntu 12.04 Server - No network connection even though web server fully works.

    sorry - I don't know anything about bind

  5. #5
    Join Date
    Mar 2006
    Beans
    18

    Re: Ubuntu 12.04 Server - No network connection even though web server fully works.

    Quote Originally Posted by steeldriver View Post
    sorry - I don't know anything about bind
    No worries at all man. I do appreciate you even taking the time to look into it.

    I am still working around it see what I can figure out. When I do, I will post the fix.

  6. #6
    Join Date
    Apr 2012
    Beans
    6,874

    Re: Ubuntu 12.04 Server - No network connection even though web server fully works.

    maybe this bug? it seems sometimes bind9 doesn't play well with resolvconf

    https://bugs.launchpad.net/ubuntu/+s...d9/+bug/933723

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •