Results 1 to 10 of 12

Thread: No audio in 12.10

Hybrid View

  1. #1
    Join Date
    Oct 2012

    No audio in 12.10

    Hey guys,

    I did a clean install of 12.10, when I open Sound Settings in gnome the only device in the list is "Dummy Output", and sound is not working.

    Sound worked fine out of the box in 12.04

    I ran alsamixer, it says my card is "HDA Intel", and chip is "Realtek ALC880". The alsamixer playback output was set to mute at first, unmuting did not fix.

    It looks like Ubuntu is finding my audio device correctly.

    mike@wucade:~$ lspci -v | grep -A7 -i "audio" 00:1b.0 Audio device: Intel Corporation 82801FB/FBM/FR/FW/FRW 
    (ICH6 Family) High Definition Audio Controller (rev 03) Subsystem: Albatron Corp. Device 2668 Flags: bus master, 
    fast devsel, latency 0, IRQ 40 Memory at d01c0000 (64-bit, non-prefetchable) [size=16K] Capabilities: Kernel driver 
    in use: snd_hda_intel Kernel modules: snd-hda-intel
    My motherboard is an Albatron PX915G-Pro, am I correct in assuming that the alsa driver for this device is snd-intel-hda? It's kinda hard to see on this alsa page

    Pulling my hair out on this one.
    Last edited by frampy; October 24th, 2012 at 12:04 AM. Reason: Make lspci output more readable

  2. #2
    Join Date
    Jun 2007

    Re: No audio in 12.10

    same problem. But under kde.

    Anyone know how to fix this?
    Last edited by alexander1; November 1st, 2012 at 11:20 PM.

  3. #3
    Join Date
    Aug 2006

    Re: No audio in 12.10

    same problem here, and this isnt a great solution (particularly on a clean install) but the 3.2 kernel still works.

  4. #4
    Join Date
    Jun 2009

    Re: No audio in 12.10

    I am having a similar problem.
    After I upgraded from 12.04 to 12.10 audio worked perfectly fine, once I booted up my computer today, the start-up sound works fine and the change volume "sound" works, other than that no media audio plays at all.
    This is on 12.10 using gnome 3 (with a workaround to have it act like gnome 2 if this causes problems).
    Card is HDA Intel,
    and the chip is Realtek ALC888.

    Edit: (For anyone else with this particular issue only) It looks like it is a glitch if you switch your computer off if you leave the audio output to headphones, the computer reset it to the speakers, but the output was still technically set to headphones, switching to headphones and back fixed it.
    Last edited by KBD20; November 8th, 2012 at 09:35 PM. Reason: False alarm issue/found solution - explaining

  5. #5
    Join Date
    Jul 2012

    Re: No audio in 12.10

    If alsamixer has correctly detected the soundcard, may be forcing Ubuntu to restart alsamixer will do the trick! Try this ...

    sudo alsa force-reload

  6. #6
    Join Date
    Aug 2009
    Ubuntu Development Release

    Re: No audio in 12.10

    Quote Originally Posted by em wai zee View Post
    If alsamixer has correctly detected the soundcard, may be forcing Ubuntu to restart alsamixer will do the trick! Try this ...
    sudo alsa force-reload
    ^^ That fixed it for me. I just logged out and back in, had no sound and a "Dummy Output" showed up in Sound Settings.
    Then I entered sudo alsa force-reload and voila back to normal.

Tags for this Thread


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts