Results 1 to 10 of 28

Thread: Upgrage to 11.10 reboot failed

Hybrid View

  1. #1
    Join Date
    Oct 2011

    Exclamation Upgrage to 11.10 reboot failed


    i made a distro upgrade for my ibookg4 to v 11.10.

    the upgrate itself had an error installing one package named firmeware... (don't know the name exactly) but afterwards finished with success.

    i rebootet after the distroupgrade and the ibook failed to boot.

    what i see when i press the power button:
    1. there is a boot menu:
    First Stage upbuntu boot, l=linux, c = cdrom
    i choose l

    2. there is a yaboot screen (i choose nothing after a few seconds the boot process continues)

    3. The cd rom makes some noise, nothing happens for about 15 s

    3. An error and the busybox is displayed:

    WARNING bootdevice may be renamed. Try root=/dev/sda3
    Gave up waiting for root device........

    then BusyBox v1.18.4 is displayed.

    when i look at /dev there is a device /dev/sda3 (wich is the root device)

    i can then mount the root device
    cd /
    mount /dev/sda3 /root

    but the same error is displayed again.

    how does i manage to get the system to boot from /dev/sda3 ?
    i don't catch the boot progress. doesn't yaboot mount the root device ?

    thanks stefan

  2. #2
    rsavage is offline Iced Almond Soy Ubuntu, No Foam
    Join Date
    Jan 2011

    Re: Upgrage to 11.10 reboot failed

    At the BusyBox terminal type the command:

    modprobe pata_macio

    then press ctrl+D to resume the boot. See post #8 for more info on this. If this doesn't work follow orginal instructions....

    My wild stab in the dark:

    At the second yaboot prompt type

    Linux root=/dev/sda3
    That is assuming you have a standard Ubuntu install on partition 3. If you are dual-booting then you may have linux installed on another partition.

    There are various ways you can setup a yaboot.conf to point to root
    You could also try setting the root value using the UUID number.

    Linux root="UUID=big-long-number-000"
    I think there has been some sort of renaming thing going off so hda3 maybe now sda3?

    Will it boot if you type at the second yaboot prompt:
    This will be a temporary fix using the 11.04 kernel. However, once you receive a kernel package update through the Update Manager the 'old' will link to a 11.10 kernel.
    Last edited by rsavage; December 6th, 2011 at 03:31 PM.

  3. #3
    rsavage is offline Iced Almond Soy Ubuntu, No Foam
    Join Date
    Jan 2011

    Re: Upgrage to 11.10 reboot failed

    Just to add some more to this:

    On some installs the yaboot.conf has this line:


    On others it has this:


    So you may have to fiddle with the boot= line too! I think the boot path is only used when you run the ybin/yabootconfig commands, so don't worry about this until you get the system running!
    Last edited by rsavage; November 2nd, 2011 at 01:53 PM.

  4. #4
    Join Date
    Oct 2011

    Smile Re: Upgrage to 11.10 reboot failed

    That did the trick.

    After booting with Param: "Linux root=/dev/sda3" i finished the distro upgrade (there were some additional packages that needed an update / install).

    after that i fixed yaboot with:
    sudo yabootconfig -r /dev/sda3

    now, everything works


  5. #5
    Join Date
    Nov 2009
    Zürich, Switzerland
    Ubuntu 9.10 Karmic Koala

    Re: Upgrage to 11.10 reboot failed

    Thanks, worked for me as well!

  6. #6
    rsavage is offline Iced Almond Soy Ubuntu, No Foam
    Join Date
    Jan 2011

    Re: Upgrage to 11.10 reboot failed

    That yabootconfig command you've found is a very neat way to do it! I'm sure a lot of people will benefit from that. Thanks for posting back with the solution!


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts