Results 1 to 10 of 17

Thread: Laptop freezes to black screen when AC power lead removed

Hybrid View

  1. #1
    Join Date
    Jan 2010
    Lubuntu 12.04 Precise Pangolin

    Laptop freezes to black screen when AC power lead removed

    Got a clean install of Ubuntu 10.10 Maverick with all updates on installation.

    I simply pull out the power lead on my Packard Bell MZ35 laptop and as the black popup notification appears telling me about my battery status the screen goes blank with a frozen cursor.
    The same happens if I start up on battery. There is no problem until the moment that the wireless connects again and the black pop-up notification appears I get the same black screen with frozen mouse cursor.

    I have to resort to a hard restart each time.

    Everything works fine plugged in i.e. LAN is wired and power is plugged in.

    Tried the advice here
    But it has not made a difference.

    My wireless card is Ralink RT2561/RT61 rev B 802.11g

    Using Comments #50 and #54 from I did the following to prevent the freezes on my Packard Bell MZ35

    I created an empty file by right clicking on the desktop and choosing "Create Document" and then "Empty File"
    Then I gave the file the name


    I repeated this to create another empty file called


    The two files were be copied to the folder /etc/pm/power.d

    I started the terminal with the command ctrl-alt-T
    navigated to the Desktop folder with

    cd Desktop
    and pasted in this command

    sudo cp pcie_aspm /etc/pm/power.d
    followed by
    sudo cp wireless /etc/pm/power.d
    Once this had been done I pulled out the power lead and found my laptop no longer crashed.
    I think a restart is necessary as within an hour my computer performed a bizarre reboot that must have been caused by confusing the pm-utils
    I have had no such crashes since.

    It has been reported here
    and here

    Last edited by JosephWheatley; January 29th, 2011 at 07:27 PM. Reason: Added links to reported bugreports and added solution
    Lubuntu 12.04 on Packard Bell BV EasyNote MZ35
    Debian 7.1 Wheezy on Asus EEE PC 1000h

  2. #2
    Join Date
    Jan 2007
    the Netherlands
    Ubuntu Development Release

    Re: Laptop freezes to black screen when AC power lead removed

    I have exactly the same problem on exactly the same type of laptop. I can confirm that this only happens when you connect are are connected when the AC power lead is unplugged and you're running on battery power.

  3. #3
    Join Date
    Aug 2010

    Re: Laptop freezes to black screen when AC power lead removed

    i have a similar issue. I am medion akoya e1210 with 10.10 running. When i remove the ac, it says critical battery, i say cancel and it runs fine. Until the screen goes to sleep(by the way screensaver does not run), at which time all is over, all is frozen. cannot ssh. need a hard start. Pretty annoying for laptop---kind of need to be able to use it on battery power.

  4. #4
    Join Date
    Jun 2006

    Re: Laptop freezes to black screen when AC power lead removed

    I have the same problem with a different laptop: Samsung Q310 and a Nvidia 9200 graphical card.

    In my case, to get to this situation I tried to solve a few other problems. Let me tell you the background:

    I upgraded my installation from Ubuntu 10.04 and everything seemed to work fine. Then I tried enabling desktop effects, so I had to enable the proprietary drivers.

    After doing this, the Screen brightness applet stopped working, and if I tried to use the FN keys plus the increase / decrease brightness special key, my keyboard would get blocked. Also the screen would not dim when on battery.

    Then I disabled the proprietary drivers (trying to go back to the previous status) and the screen would dim and the brightness applet would work. But the keyboard would get blocked anyway if I used the FN key to try to decrease or increase the brightness, as before.

    Then I started installing / uninstalling newer versions of the proprietary drivers from "nvidia vdpau" repository, and discovered this thread. At some point something fixed the issue with the screen brightness and the proprietary drivers, but I'm still having the keyboard locked up when using the FN key to increase / decrease the brightness, and in addition when the screen dims below half the normal brightness (which can happen with the screen brightness applet or when unplugging the AC), my screen turns completely black, and freezes, so I can't do anything with it, as described by the users above.

    Any suggestion on how to fix this would really be appreciated

  5. #5
    Join Date
    Apr 2010
    Texas, USA
    Ubuntu Development Release

    Re: Laptop freezes to black screen when AC power lead removed

    I'm having issues with my netbook acting strangely in relation to whether or not it detects the power chord to be plugged in, but I'm in 10.04. This comes after a recent update. It's not quite the same, but it is causing serious problems. This happens regardless of whether not a charged battery is in.

  6. #6
    Join Date
    Jan 2008
    Rotterdam The Netherlands
    Ubuntu 10.10 Maverick Meerkat

    Re: Laptop freezes to black screen when AC power lead removed

    I've the same problem as above after upgrading from 10.04 to 10.10!
    If on battery I can start my laptop but after login to ubuntu the screen goes black, mouse freezes and num & caps lock keep blinking. A hard reset is necessary to reboot.
    The laptop works fine when plugged in. But when I take the power plug out it freezes as described above. When I disable the wireless card (through function key) and then take the power plug out everything works fine till I put the wireless card back on!

    I've MEDION AKOYA which is almost the same as a MSI S271. The wireless card (Ralink RT2561/RT61) has always been the problem with upgrades! Anyone has an idea how to fix it?

Tags for this Thread


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts