Page 1 of 3 123 LastLast
Results 1 to 10 of 107

Thread: Broadcom Wireless STA driver (wl) Ubuntu 9.10/10.04

Hybrid View

  1. #1
    Join Date
    Mar 2007
    Location
    Netherlands
    Beans
    12
    Distro
    Ubuntu Development Release

    Post Broadcom Wireless STA driver (wl) Ubuntu 9.10/10.04

    Problem using Broadcom Wireless in Ubuntu 9.10/10.04 because it is not supported by b43 driver ?

    Assuming you have tried all normal installation procedures like using the Hardware Drivers tool and you still do not have a working WiFi setup this is what you must do:

    1. Download the Broadcom drivers: http://www.broadcom.com/support/802.11/linux_sta.php
    2. Unpack and modify the ‘src/wl/sys/wl_linux.c‘:
    Line 35 (after #include <linux/etherdevice.h>) add:
    #include < linux/sched.h >
    3. Compile the code with: make
    4. Copy the new driver: sudo mv wl.ko /lib/modules/$(uname -r)/kernel/drivers/net/wireless
    5. Update dependencies: sudo depmod -a
    6. Modify the blacklist to include the ‘b43′ and ’ssb’ drivers /etc/modprobe.d/blacklist.conf (Add below the bcm43xx blacklist)

    The part above you probably have seen a few times while googling for the answer. But there is a small problem, as you would have noticed, the ‘ssb‘ driver cannot be blacklisted. It is included in the initrd as I remember from the ubuntuforums. To solve this issue modify the /etc/rc.local to include before the exit(0):

    Code:
    rmmod ssb
    modprobe wl
    Now on startup the ssb gets removed and after that the new wl gets inserted. Adding wl to the /etc/modules will not help because the removing needs to be done first.
    So with the /etc/rc.local modification everything happens in the correct order for perfect WiFi.

    This was tested multiple times on a MacBook Pro with the Broadcom 4328 chipset and should work for all chipsets not supported by the b43 drivers.

    Update:
    Not all systems include the 'linux/sched.h' file. Install the 'linux-headers-generic' package if you get errors. The generic package is a meta package that should install the propper package for your kernel. If it isn't working install with
    Code:
    sudo apt-get install linux-headers-$(uname -r)
    Last edited by owhno; February 16th, 2010 at 05:25 PM.

  2. #2
    Join Date
    Jan 2010
    Beans
    1

    Re: Broadcom Wireless STA driver (wl) Ubuntu 9.10/10.04

    Thanks! Solved my broadcom issue on Ubuntu 10.04

  3. #3
    Join Date
    Nov 2007
    Beans
    7

    Re: Broadcom Wireless STA driver (wl) Ubuntu 9.10/10.04

    hi thanks for your help
    although including linux/sched.h in wl/sys/wl_linux.c is not working for me:
    linux.c:35:27: error: linux/sched.h : No such file or directory
    do i have to add sched.h from somewhere?

  4. #4
    Join Date
    Mar 2007
    Location
    Netherlands
    Beans
    12
    Distro
    Ubuntu Development Release

    Re: Broadcom Wireless STA driver (wl) Ubuntu 9.10/10.04

    As I'm now installing it again (daily build from 2 days ago) I see no problem with it. But as I haven't tested it with 9.10 it is probably a missing package. As sched.h is a header file the obvious answer would be that the package linux-header-generic isn't installed (or use the linux-header-$(uname -r) package. This is by default installed on testing systems so probably it is missing on 9.10.

  5. #5
    Join Date
    Mar 2008
    Location
    Sussex, UK
    Beans
    1,326
    Distro
    Ubuntu

    Re: Broadcom Wireless STA driver (wl) Ubuntu 9.10/10.04

    This worked on my Dell which is not a Mini though that's what's mentioned. Very easy in _buntus 9.10
    http://www.ubuntumini.com/2009/11/br...in-karmic.html

    Hope it helps someone?!

  6. #6
    Join Date
    Mar 2007
    Location
    Netherlands
    Beans
    12
    Distro
    Ubuntu Development Release

    Re: Broadcom Wireless STA driver (wl) Ubuntu 9.10/10.04

    You are true that that fixed works for most options, but this is for non supported bmcwl cards. But thanks for mentioning it, because probably someone will stumble on this with a card that works with the normal installation

  7. #7
    Join Date
    May 2010
    Beans
    1
    Distro
    Edubuntu

    Lightbulb Re: Broadcom Wireless STA driver (wl) Ubuntu 9.10/10.04

    Quote Originally Posted by earthpigg View Post
    in case anyone using a Dell Mini 9 comes across this:

    i was able to get wifi working on 10.04 without ever plugging into wired internet after installing from thumb drive.

    1) install ubuntu 10.04 from thumb drive.
    2) boot normally.
    3) insert the thumb drive you just installed from.
    4) open the file manager, go to the thumb drive, and navigate to pool/restricted/b/bcmwl, and double click on the .deb in there. it will tell you it needs 3 dependancies - make a mental note of which three.
    5) navigate back to pool/main, find those deps and install them.
    6) install the .deb in pool/restricted/b/bcmwl
    7) reboot
    Even this didn't work for me (Ubuntu 10.04 64 bit), although I see many people have had success with this method!. I was getting various errors when I attempted to install (and several attempts to re-install) the bcmwl-kernel-source package manually via synaptic.

    Assuming you have attempted to install bcmwl-kernel-source and its dependencies manually, received errors during its install and synaptic is showing bcmwl-kernel-source as 'installed'... this may solve the problem.

    Go into synaptic and...

    completely remove bcmwl-kernel-source AND dkms


    then, whilst still in synaptic

    install bcmwl-kernel-source



    For me this did the trick, I'm not sure why. (removing dkms was the golden ticket). I then went back into Hardware Drivers and driver was showing as activated but not in use. All it took then was a quick reboot and

    Hope this helps someone!
    Last edited by caffeinepill; May 5th, 2010 at 09:07 AM.

  8. #8
    Join Date
    May 2008
    Beans
    151

    Re: Broadcom Wireless STA driver (wl) Ubuntu 9.10/10.04

    Quote Originally Posted by raumkundschafter View Post
    hi thanks for your help
    although including linux/sched.h in wl/sys/wl_linux.c is not working for me:
    linux.c:35:27: error: linux/sched.h : No such file or directory
    do i have to add sched.h from somewhere?
    Has anyone resolved this error? I also get this, even though I installed the linux-headers-generic package.

  9. #9
    Join Date
    May 2008
    Beans
    151

    Re: Broadcom Wireless STA driver (wl) Ubuntu 9.10/10.04

    Quote Originally Posted by raumkundschafter View Post
    hi thanks for your help
    although including linux/sched.h in wl/sys/wl_linux.c is not working for me:
    linux.c:35:27: error: linux/sched.h : No such file or directory
    do i have to add sched.h from somewhere?
    I think there might be a typo. Try removing the spaces from the line, e.g. "#include <linux/sched.h>".

    Also, try removing the linux-headers-generic package and reinstalling. That fixed that problem for me.

    Unfortunately, wireless still doesn't work, but at least it compiles...

  10. #10
    Join Date
    May 2010
    Beans
    1
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Broadcom Wireless STA driver (wl) Ubuntu 9.10/10.04

    Kamalkhadka, DrAcid: From the terminal go to the folder where you saved the source code. It should be a file called "Makefile" in there, then type:
    $ make

    I too have followed the above instructions but the fix didn't permanently rectify the problem.

    I instead used the rather crude hack below. It'll effectively hard-code access to one specified wireless network, so no good if you frequently access different networks.

    Make sure wireless-tools is installed, if not:
    $ sudo apt-get install wireless-tools

    Verify your network devices is working and wireless networks are detected
    $ iwconfig
    $ sudo iwlist scan

    Make sure wpa-supplicant is installed, if not:
    $ sudo apt-get install wpasupplicant

    Convert your WPA ASCII password to hex:
    $ wpa_passphrase <ssid> [passphrase]
    - <ssid> is the name of the Wireless network / router
    - [passphrase] is your WPA ASCII password
    - Copy down the value after “psk=” that is the hex version of your WPA ASCII password

    Using dhcp and WPA here is what is added to /etc/network/interfaces

    #The wireless interface
    auto wlan0
    iface wlan0 inet dhcp
    wpa-ssid <SSID of your router>
    wpa-ap-scan 1
    wpa-key-mgmt WPA-PSK
    wpa-psk <the PSK that you wrote down>

    *note wlan0 is the name of the wireless interface in this example

    Restart the network
    $ sudo /etc/init.d/networking restart

    Revoke read-permission from others on /etc/network/interfaces
    $ sudo chmod o=-r /etc/network/interfaces

Page 1 of 3 123 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •