Results 1 to 8 of 8

Thread: Howto: Belkin N Wireless USB Adapter (F5D8053) Native Driver

Hybrid View

  1. #1
    Join Date
    Jun 2006
    Pulham Market, England

    Howto: Belkin N Wireless USB Adapter (F5D8053) Native Driver

    I searched around for some time trying to get an explanation on how to get the Belkin N Wireless USB Adapter (F5D8053) to work in Ubuntu 9.10 (karmic). I had tried several times to get the native ralink driver working, but to no avail. This afternoon I managed it, and so I thought I would share what I'd learned, as there seemed to a good few others with similar problems.

    Get the driver from Ralink
    Visit and download RT2870USB(RT2870/RT2770). The version I used was Extract the downloaded driver (RT2870_LinuxSTA_V2.3.0.0.tar.tar.bz2) and cd into the directory:
    george@transistor:~$ tar xfj RT2870_LinuxSTA_V2.3.0.0.tar.tar.bz2 
    george@transistor:~$ cd RT2870_LinuxSTA_V2.3.0.0/
    Configure the Driver
    Next we must configure the driver, as explained in README_STA:
    george@transistor:~/RT2870_LinuxSTA_V2.3.0.0$ nano os/linux/
    We must edit two options - Find these two options:
    ... and change them to
    Use CTRL+X to exit, answering Y to save changes, and ENTER to use the original filename.

    Compile & Install the Driver
    Next I compiled the driver. You will need to install build-essential and kernel headers. Im pretty sure thats all you need, but I am unsure. I had already installed them a long time ago.
    george@transistor:~/RT2870_LinuxSTA_V2.3.0.0$ sudo apt-get install build-essential linux-headers-generic
    george@transistor:~/RT2870_LinuxSTA_V2.3.0.0$ make
    Once make finishes (if it errors, you will need to fix this first of course - it compiled first time for me) you need to install the drivers. This must be done as root, and is done as follows:
    george@transistor:~/RT2870_LinuxSTA_V2.3.0.0$ sudo make install
    [sudo] password for george: <USER PASSWORD HERE>
    Blacklist the old drivers & force use of the new ones
    To force the use of the compiled driver, called rt2870sta, you need to blacklist the ones loaded Karmic as default. To do this, enter the following command:
    george@transistor:~$ sudo nano /etc/modprobe.d/blacklist-rtusb.conf
    This opens the nano text editor as before. Add the following to the file /etc/modprobe.d/blacklist-rtusb.conf
    # Blacklist the default usb drivers for rslink card
    blacklist rt2500usb
    blacklist rt2800usb
    Use CTRL+X to exit, answering Y to save changes, and ENTER to use the original filename.

    The simplest thing to do at this point is reboot. If you know what you're doing, you can easily use modprobe to remove the default modules and to insert the newly compiled module into the kernel. Something like the below:

    modprobe -r rt2500usb rt2800usb
    modprobe -i rt2870sta
    It works
    george@transistor:~$ lsmod | grep rt2870
    Module                  Size  Used by
    rt2870sta             624696  1

  2. #2
    Join Date
    Jan 2009

    Smile Re: Howto: Belkin N Wireless USB Adapter (F5D8053) Native Driver

    Wow...I'm new to Linux and have been trying to get my Belkin usb wireless adapter to work with Linux Mint 8. Finally found this thread. All other threads I read required some knowledge of Linux that I haven't absorbed yet. This one is in "English" and got me working in 5 minutes. Thank you very much!

  3. #3
    Join Date
    May 2008
    Ubuntu 10.04 Lucid Lynx

    Re: Howto: Belkin N Wireless USB Adapter (F5D8053) Native Driver

    The driver is almost always there on the file system so there is no need to download it.

    The really easy way around this is to ensure that the correct driver is loaded and installed. Run the following...

    test@test:~$ sudo modprobe -l | grep rt28[67].*

    **Your output should show these in the output**


    If they are not in the output you should check to see if they are on your system.

    test@test:~$ sudo find /* -name "rt28[67]*"

    If those ko files are located on your system you should see somthing like the following:


    Install the ko files under:

    sudo insmod /lib/modules/2.6.32-21-generic/kernel/drivers/staging/rt2870/rt2870sta.ko

    sudo insmod /lib/modules/2.6.32-21-generic/kernel/drivers/staging/rt2860/rt2860sta.ko

    sudo depmod -a

    You are almost done... just check what modules are currently loaded for your belkin.

    test@test:~$ sudo lsmod | grep rt28*

    If you have "rt2800usb" as a result you will need to black list that driver

    sudo gedit /etc/modprobe.d/blacklist.conf

    Goto the bottom of the file and add the following line and save the file:

    blacklist rt2800usb

    Now reboot and you should be all done.

  4. #4
    Join Date
    Jun 2010

    Re: Howto: Belkin N Wireless USB Adapter (F5D8053) Native Driver

    I am a total noob to Linux. I found this thread and read thru it after starting my own thread asking how to do exactly what you said to do. However, never having work with linux other then Downloading and installing it I had know idea what you were trying to tell me to do. So i referenced this thread in mine and got the help i needed. So if you read this thread and don't understand what to do. Go to http://ubuntuforums.orgshowthread.php?t=1515837 It is explained in the simplest form possible and it works Great! Thank you so much for this information. I couldn't have connected with out this thread.


  5. #5
    Join Date
    Jul 2010

    Re: Howto: Belkin N Wireless USB Adapter (F5D8053) Native Driver

    Ok, so I've been trying to get this stupid adapter working since I don't know when. I thought that with the release of Lucid that a lot of problems would clear up by themselves (this was the case with my laptop). So I've done everything in this thread.

    I used this command [la@la-desktop:~$ sudo modprobe -l | grep rt28[67].*] and got the following:

    So I thought that I might have something wrong, so I continued to use the following commands as instructed in the previous posts:

    la@la-desktop:~$ sudo insmod /lib/modules/2.6.32-21-generic/kernel/drivers/staging/rt2870/rt2870sta.ko
    la@la-desktop:~$ sudo insmod /lib/modules/2.6.32-21-generic/kernel/drivers/staging/rt2860/rt2860sta.ko
    la@la-desktop:~$ sudo depmod -a
    la@la-desktop:~$ sudo lsmod | grep rt28*
    rt2860sta 481561 0
    rt2870sta 461811 0

    I rebooted, nothing. My adapter usually shows a blinking light when it's on and connected, but it doesn't even register that it's on in Ubuntu. I don't have any internet on the ubuntu side of my computer and I don't know what to do. I'm not sure if this is significant at all, but when I ran this command:
    george@transistor:~/RT2870_LinuxSTA_V2.3.0.0$ sudo apt-get install build-essential linux-headers-generic
    It said that there was no build-essentials file to install. I'm not sure if this is on account of me not having internet in ubuntu or what. If this is the problem, then can someone please give me a file so I can install build-essentials? I've tried so hard to get this to work and nothing seems to be working. I'm dead-set on getting Ubuntu to work. I really like the look and feel of the OS and I would love using it.

    Any help would be greatly appreciated.

  6. #6
    Join Date
    Nov 2009
    Ubuntu 10.04 Lucid Lynx

    Re: Howto: Belkin N Wireless USB Adapter (F5D8053) Native Driver

    worked perfect, thanks!

Tags for this Thread


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts