Results 1 to 2 of 2

Thread: Disable SHMConfig in Karmic

Hybrid View

  1. #1
    Join Date
    Nov 2007
    Beans
    465

    Disable SHMConfig in Karmic

    Hello!

    I, along with a few others on these forums, have an Acer 5920 laptop, which is equipped with both a Synaptics Touchpad, and a set of touch-sensitive media keys, which are, in fact, a second synaptics touchpad.

    Previously, we had been able to use gsynaptics to configure the touchpad behaviour by this:

    Code:
    <?xml version="1.0" encoding="UTF-8"?>
    <deviceinfo version="0.2">
    
      <device>
        <match key="input.originating_device" string="/org/freedesktop/Hal/devices/platform_i8042_i8042_AUX3_port">
            <merge key="input.x11_options.SHMConfig" type="string">True</merge>
            <merge key="input.x11_options.RTCornerButton" type="string">2</merge>
            <merge key="input.x11_options.RBCornerButton" type="string">3</merge>
            <merge key="input.x11_options.LTCornerButton" type="string">4</merge>
            <merge key="input.x11_options.LBCornerButton" type="string">5</merge>
            <merge key="input.x11_options.TapButton1" type="string">1</merge>
            <merge key="input.x11_options.TapButton2" type="string">2</merge>
            <merge key="input.x11_options.TapButton3" type="string">3</merge>
            <merge key="input.x11_options.PalmDetect" type="string">0</merge>
            <merge key="input.x11_options.PalmMinWidth" type="string">0</merge>
            <merge key="input.x11_options.PalmMinZ" type="string">0</merge>
        </match>
      </device>
    </deviceinfo>
    in the file /etc/hal.fdi.policy/touchpad.fdi. That worked fine, because up until Jaunty, SHMConfig was 'off' by default. Now, I need to specify that I don't want SHMConfig for the Media Keys touchpad, and I've attempted this in another fdi file:

    Code:
    <?xml version="1.0" encoding="UTF-8"?>
    <deviceinfo version="0.2">
    
      <device>
        <match key="input.originating_device" string="/org/freedesktop/Hal/devices/platform_i8042_i8042_AUX2_port">
            <merge key="input.x11_options.SHMConfig" type="string">False</merge>
            <merge key="input.x11_options.RTCornerButton" type="string">0</merge>
            <merge key="input.x11_options.RBCornerButton" type="string">0</merge>
            <merge key="input.x11_options.LTCornerButton" type="string">0</merge>
            <merge key="input.x11_options.LBCornerButton" type="string">0</merge>
            <merge key="input.x11_options.TapButton1" type="string">0</merge>
            <merge key="input.x11_options.TapButton2" type="string">0</merge>
            <merge key="input.x11_options.TapButton3" type="string">0</merge>
            <merge key="input.x11_options.PalmDetect" type="string">0</merge>
            <merge key="input.x11_options.PalmMinWidth" type="string">10</merge>
            <merge key="input.x11_options.PalmMinZ" type="string">200</merge>
        </match>
      </device>
    
    </deviceinfo>
    Unfortunately, this isn't working. Is it possible to turn off SHMConfig for a touchpad like this? Or some other way? It effects not only the configuring of the main touchpad, but also syndaemon, which is a pretty necessary utility.

    All advice appreciated!

    Charlie

  2. #2
    Join Date
    Apr 2010
    Beans
    2

    Re: Disable SHMConfig in Karmic

    Check out what worked for me here:

    http://ubuntuforums.org/showpost.php...9&postcount=28

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •