Results 1 to 10 of 33

Thread: x11vnc won't start from /etc/gdm/Init/Default

Hybrid View

  1. #1
    Join Date
    Mar 2009
    Beans
    23

    x11vnc won't start from /etc/gdm/Init/Default

    Problem started after upgrade from 9.04 to 9.10.

    On 9.04, I started x11vnc by executing it from /etc/gdm/Init/Default. The command I use is below (personal info replaced with '~':

    /usr/bin/x11vnc -o /var/log/x11vnc -noxdamage -verbose -auth /var/lib/gdm/:1.Xauth -rfbauth /etc/.vncpasswd -rfbport 5900 -shared -forever -bg -scale 3/4 -users ~~~~~ -solid \#003399 -afteraccept "gconftool-2 --type bool --set /desktop/gnome/background/draw_background false" -gone "gconftool-2 --type bool --set /desktop/gnome/background/draw_background true"

    This worked fine, and allowed me to see the GDM login screen from a VNC session on bootup. I later set GDM to auto-login.

    After upgrading to 9.10, x11vnc is not executed, despite that line being in /etc/gdm/Init/Default. The -o option indicates the file to log to, and that file is not changed upon restart of gdm. Placing that line in /etc/gdm/PreSession/Default causes x11vnc to run without error, when autologin is enabled, but I would like x11vnc to be available with the login screen.

    Any ideas why gdm is ignoring /etc/gdm/Init/Default now?

  2. #2
    Join Date
    Dec 2006
    Beans
    810

    Re: x11vnc won't start from /etc/gdm/Init/Default

    I've heard that GDM is much changed in 9.10 and has significantly less functionality.

    However, I suspect /etc/gdm/Init/Default should still be honored. Maybe a mis-configuration from your upgrade?

    BTW, the new GDM no longer support KillInitClients=false:
    and this requires additional workarounds, but I don't think you are at that point yet.
    Last edited by krunge; October 31st, 2009 at 04:41 AM.

  3. #3
    Join Date
    Mar 2009
    Beans
    23

    Re: x11vnc won't start from /etc/gdm/Init/Default

    Thanks!

    I've read your posts in that thread and am grateful for your help. I have compiled and installed the updated version you have there. I was under the impression that x11vnc would manage to log something to the specified logfile before GDM gives it the axe due to KillInitClients no longer being respected. If that is not the case, then maybe I should try the "x11vnc -env X11VNC_AVOID_WINDOWS=120" trick and see if it will write anything to the logfile. At that point I would know that it's doing something. I read somewhere that someone threw a "touch /var/some-file-that-doesnt-exist" into the Init/Default script, and it didn't seem to execute that, either. That's what I'll do if the first idea fails.

    Thanks again!

  4. #4
    Join Date
    Dec 2006
    Beans
    810

    Re: x11vnc won't start from /etc/gdm/Init/Default

    Quote Originally Posted by heltoupee View Post
    I have compiled and installed the updated version you have there. I was under the impression that x11vnc would manage to log something to the specified logfile before GDM gives it the axe due to KillInitClients no longer being respected. If that is not the case, then maybe I should try the "x11vnc -env X11VNC_AVOID_WINDOWS=120" trick and see if it will write anything to the logfile.
    As it dies it should log the XIO error and a bit more, e.g:
    Code:
    caught XIO error:
    15/04/2008 14:12:17 deleted 50 tile_row polling images.
    The I/O error should be obvious: the X server closed its socket with x11vnc. Is this logging not happening for you?

    I am very curious to see how this works on ubuntu 9.10, but don't have the time to set one up right now.

    For the touching a filename, putting this in Init/Default should work:
    Code:
    (x11vnc -whatever ...; touch /var/tmp/foofile) &
    Thanks,

    Karl

  5. #5
    Join Date
    Dec 2006
    Beans
    810

    Re: x11vnc won't start from /etc/gdm/Init/Default

    Well, I set up ubuntu 9.10 in a Virtualbox instance and now I see more what is going on.

    In the new GDM, for the Login Greeter they start up gnome-session, dbus-launch, and metacity! So x11vnc's heuristics to try to guess that the display manager login window is still up and the window manager hasn't started are foiled (because the gdm login greeter looks like a full session.)

    No wonder GDM got rid of KillInitClients=false, they want all of their doo-dad windows to be destroyed after the user logs in!

    I've uploaded a new x11vnc 0.9.9 tarball today that tries to detect this as well (it looks for windows with names like 'gdm-simple-greeter'.) Please try it out when you get the chance.

    Thanks.

  6. #6
    Join Date
    Feb 2009
    Location
    Enigma
    Beans
    64
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: x11vnc won't start from /etc/gdm/Init/Default

    Krunge,

    I apologize that I have not had time to get back to you on this, and I sincerely appreciate your reply. I have been deep in some AD stuff at work, and I have had to put my true love, *nix, on the shelf and travel off to "AD Land."

    I discovered something similar, somewhat accidentally. I disabled visual effects last night while logged in via x11vnc (i use your s/w to control all of the machines at my home from my laptop), as I was leting an avi play and the visual effects were jerking the image around. GDM crashed and restarted. After that, I noticed that I was able to login w/o gdm killing the x11vnc process. I meant to post back, but I wanted to wait until I had time to pursue the different options that you presented.

    All of that to say: I believe that you are on the right track, sir!

    I will post back more, when I can dig out of M$ hole that I am in.

    Thank you, Krunge.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •