Results 1 to 10 of 437

Thread: Toshiba L505D ACPI issue with 9.1/9.04

Hybrid View

  1. #1
    Join Date
    Oct 2009
    Beans
    9

    Toshiba L505D ACPI issue with 9.1/9.04

    I ran into some problems installing 9.10 RC, I also had the same problems with 9.04 so this isn't anything specific to 9.1.

    I have a Toshiba L505D-S5992 laptop. It has an Amd Turion II and Ati Radeon 4100 graphics. I had to run the install by selecting the "acpi=off" option from the F6 menu, and I also had to add "acpi=off" to the Grub kernel options to get the installed system to boot. If I don't use "acpi=off", I see a bunch of errors flying by, but the startup dies with the following: '/sbin/modprobe -b acpi:lnxvideo:' unexpected exit with status 0x0009.

    While I can get the system up by turning off the acpi option, I'm assuming I'm going to be missing some acpi functionality which might be pretty nice to have on a laptop. Any ideas/suggestions?

  2. #2
    Join Date
    Oct 2009
    Beans
    9

    Re: Toshiba L505D ACPI issue with 9.1/9.04

    Some additional information: running lspci gives me the following info for my video hardware:

    01:05.0 VGA compatible controller: ATI Technologies Inc Device 9712

    lspci -nn gives this:

    01:05.0 VGA compatible controller [0300]: ATI Technologies Inc Device [1002:9712]

    I read a thread on a debian board that seemed to indicate the current open source ATI drivers don't have support for this chipset, which would explain why I can only run 1024x768 resolution once I am in gnome.

    But why would I have to disable acpi? Can the hardware detection not deal with an unknown device?

  3. #3
    Join Date
    Nov 2005
    Location
    San Jose, CA
    Beans
    144
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Toshiba L505D ACPI issue with 9.1/9.04

    Just got the Toshiba L505D-S5992. I too have the same problem.

    I can boot of the 9.10 live USB only with acpi=off.

    I have not installed 9.10 desktop-i386 final. Will install only if there is a solution to the above!

    Suggestions anyone?
    Running Precicse on AMD A8-3870k, Asrock A75m-itx Mobo, 8 Gb DDR3 1600 RAM,120 GB OCZ Agility 3, 2 x 320 GB Hitachi HDD.

  4. #4
    Join Date
    Nov 2009
    Beans
    3

    Re: Toshiba L505D ACPI issue with 9.1/9.04

    I do have a similar problem with a Toshiba X200 and 9.10. 9.04 used to work perfectly. I've installed 9.10 final. Neither the installed version nor the live cd boots without "acpi=off". Without it, I see the error message related to "modprobe -b :acpi:LNXVIDEO:". I tried to boot the latest "grml" which has a 2.6.31 kernel, too. It aborts with the same error message.

    Note: My machine has an Intel CPU and a nvidia graphics card.

    01:00.0 VGA compatible controller [0300]: nVidia Corporation G84 [GeForce 8700M GT] [10de:0409] (rev a1)

    Any idea? How shall I continue?

    Best regards, Uli

  5. #5
    Join Date
    Feb 2008
    Location
    Greece
    Beans
    Hidden!
    Distro
    Ubuntu 10.04 Lucid Lynx

    Arrow Re: Toshiba L505D ACPI issue with 9.1/9.04

    Nothing definite just a suggsestion.Try the 'noapic' kernel boot option.
    Just a thought ,though this could fix your problem since it's laptop related.

  6. #6
    Join Date
    Sep 2009
    Beans
    12

    Re: Toshiba L505D ACPI issue with 9.1/9.04

    since your toshiba laptop has juest been bought for not long ,you could turn to after-service for professional help.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •