Results 1 to 10 of 342

Thread: Ipod Nano 5G with linux?

Hybrid View

  1. #1
    Join Date
    Aug 2007

    Ipod Nano 5G with linux?

    Hi all,

    I was recently given a new Fifth Generation iPod Nano, the one with a video camera. I can't get it to see songs that I've transferred onto it.

    It mounts at /media/IPOD. Amarok 2.0.1, gtkpod and Songbird (latest versions as of this post) can see it, correctly recognise it as an iPod and transfer music to/from it with no error message. The files definitely make it onto the iPod, as Songbird can see and play the files that Amarok put there and vice versa. Additionally, exploring the iPod with a file browser shows the renamed music files.

    Despite this, the iPod thinks it has "0 songs" on it. I created a "SysInfo" file with the firewireguid as described here, (down at the moment? google cache) but this didn't help.

    I assume that Apple have changed something about how files are put onto the new iPod nano's song database and open software hasn't caught up yet.

    1) Has anyone persuaded the new iPod Nanos to work with linux?
    2) If so, how can I do the same?
    3) If the fix needs something very difficult (e.g. finding a new key for signing the iPod's track database), what's your gut feeling for how long this tends to take after a new iPod release?

    I'm using kubuntu 8.10.

  2. #2
    Join Date
    Jan 2008

    Re: Ipod Nano 5G with linux?

    I am having the same problem with Ubuntu 9.04(Gnome) and the 5th Gen Nano. It says it's syncing, the music files are on the nano, but it still says zero songs.

    Using gtkpod 0.99.14 and libgpod 0.7.0.

  3. #3
    Join Date
    Aug 2007

    Re: Ipod Nano 5G with linux?

    As a workaround, I've installed virtualbox, installed a spare Windows XP licence in a virtual machine then installed iTunes on it and allowed the windows virtual machine to see my iPod.

    So now I'm using the latest version of iTunes to control my iPod. I hadn't realised what a nice piece of software it is.

    This setup is working well, but I'd still be grateful for a way to use my iPod with native linux apps (Amarok, Songbird, etc).

    Can anyone make a suggestion?
    Last edited by Graphite; September 16th, 2009 at 05:27 PM.

  4. #4
    Join Date
    Nov 2008

    Re: Ipod Nano 5G with linux?

    Have you tried rhythmbox yet? I have used this for 3rd and 4th generation nanos without any issues. To use it just import the music files to rhythmbox then you would just drag the album or artist to the ipod icon on the left panel. It basically works similar to itunes when uploading music. When finished transferring music over to your ipod, simply click the eject button that appears to the right of your ipod icon in the left panel. This should do the trick. Let me know if rhythmbox works better for you.

  5. #5
    Join Date
    Sep 2009

    Re: Ipod Nano 5G with linux?

    I'm pretty sure there is not yet a linux application able to handle the nano 5g.
    I had to install virtual box with a Xp of the Caribbean and use iTunes.
    Nasty, but it works.

  6. #6
    Join Date
    Jan 2008

    Re: Ipod Nano 5G with linux?

    I tried it with rhythmbox, banshee and gtkpod. All of them can see the same music on the ipod, but the ipod itself still says "0 songs" when disconnected.

    My 4th Gen nano works just fine, it's just the 5th gen one that doesn't.

  7. #7
    Join Date
    Mar 2008
    Normal, IL

    Re: Ipod Nano 5G with linux?

    but how do you create new platlists and sinc them onto the ipod...
    (i have and ipod nano 3G)
    -ASUS U46: Intel Core I5(Sandy Bridge) 8 gb Ram, Integrated Graphics card. Currently running Ubuntu 13.04(64bit)

  8. #8
    Join Date
    Mar 2010

    Re: Ipod Nano 5G with linux?

    First I'd like to thank all the committed people in this community. I'm new to Linux (I don't know much about computers and software anyways...) and so far i got to solve all my problems just by searching the forums. Good work out there.
    As you can probably tell from my spelling I'm no native speaker, so please excuse any mistakes i make.

    I am running 9.10 Karmic Koala and followed Greya's guide for the 32 bit version. Well.. it didn't quite work out as planned.
    When I try to install Rhythmbox from the software centre afterwards, I get the following error message:

    (Reading database ... 5% (this goes on until 100%)

    (Reading database ... 285672 files and directories currently installed.)
    Unpacking libgpod4 (from .../libgpod4_0.7.2-1ubuntu1_i386.deb) ...
    dpkg: error processing /var/cache/apt/archives/libgpod4_0.7.2-1ubuntu1_i386.deb (--unpack):
    trying to overwrite '/usr/lib/', which is also in package libgpod 0:0.7.92-1
    Unpacking libgpod-common (from .../libgpod-common_0.7.2-1ubuntu1_i386.deb) ...
    dpkg: error processing /var/cache/apt/archives/libgpod-common_0.7.2-1ubuntu1_i386.deb (--unpack):
    trying to overwrite '/usr/share/hal/fdi/policy/20thirdparty/20-libgpod-sysinfo-extended.fdi', which is also in package libgpod 0:0.7.92-1
    Selecting previously deselected package media-player-info.
    Unpacking media-player-info (from .../media-player-info_3-0ubuntu1_all.deb) ...
    Selecting previously deselected package rhythmbox.
    Unpacking rhythmbox (from .../rhythmbox_0.12.5-0ubuntu5.2_i386.deb) ...
    Processing triggers for hal ...
    Regenerating hal fdi cache ...
    hal start/running, process 10759
    Processing triggers for man-db ...
    Processing triggers for hicolor-icon-theme ...
    Processing triggers for desktop-file-utils ...
    Errors were encountered while processing:
    As long as i don't uninstall Rhythmbox via the terminal, ubuntu keeps trying to make me install libgpod4 by using the update manager, which also produces error messages about missing dependencies and so on.

    But this won't be my biggest problem, as I could probably solve it by just removing the changes.

    GTKPOD recognises my iPod nano 5g (i already had music on it, i am/was using windows back home. Unfortunately i only have my netbook available until the end of june, although i could probably find an internet-cafe with windows where i could install iTunes. Running iTunes on WINE didn't work out so far, my netbook seems to be too weak, it freezes during the installation).
    I also installed gtkpod-aac, as I kept getting error messages when I imported big parts of my music in gtkpod and i was optimistic/dumb enough to do additional changes before checking if everything works out... well, I hope this didn't cause my problem.
    Even though I didn't change anything on my iPod except for letting gtkpod recognise all of its data [edit: oh, i deleted an empty playlist which i accidentally created in windows to see if everything works. forgot about that], my iPod now tells me there wouldn't be any music on it. Checking the "Settings - About" my iPod now says 7.2GB (all the music on it) would be consumed by "other".
    gtkpod still finds the music on my iPod and even manually browsing it reveals the music to be there - i can even open the mp3s on my iPod with a music player on my netbook.

    Anyways, copying new music on the iPod via gtkpod doesn't seem to work. gtkpod says it's there, my iPod begs to differ.
    What shall I do now? Judging from the other posts here, the old patches in this thread aren't necessary any more and I am sort of anxious about breaking even more.
    Whether I could restore the music that's on it (I read something about connecting the iPod to iTunes after putting music on it to fix the playlists in this thread) or even get it to work with Linux... anything would be fine.
    Last edited by irdo; March 28th, 2010 at 06:39 AM.

  9. #9
    Join Date
    Feb 2011

    Re: Ipod Nano 5G with linux?

    I downloaded Banshee Media Player and hooked my 5g Nano right up and transferred songs right on to it. No extra downloaded stuff or anything technical needed.

  10. #10
    Join Date
    May 2009

    Re: Ipod Nano 5G with linux?

    Confirmed with Ubuntu 10.10 & last banshee

Tags for this Thread


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts