Are you sure this package is even available for Lucid? I don't see it using aptitude search, in Synaptic, nor in Ubuntu Packages Search. My apt output is different:

$ sudo apt-get install...