You need to using a more recent version of Alsa, for your sound to work. Release 1.18 is the default in Ubuntu 9.04, it needs to be upgraded to Release 1.20 > or 1.21.

I just bought a CQ61 and...