I wouldn't know of any browsers for 14 year old unsupported operating system and would not suggest exposing your network to the possible security risks.