Why not use modern Linux? [ Xubuntu | Lubuntu ] 22.04.4 would run very well on that system.