Welcome to the forums.
1st - 11.10 hasn't been supported since 2012. You really need to update to 12.04. I didn't research that compaq 515 to know if there are any issues with doing an update. ...