The version of conky in 18.04 is currently the same as in 17.10. Does it work in 17.10?

Conky is maintained in Debian so you may want to report bugs there.