Should install fine, all those listed i386 packages are still built for Ubuntu up to at least 23.10.
(That also includes all depends those have as well)

Not sure if the OP did it, but you need to...