Would be very problematic. While you can co-install many amd64 & i386 libraries not all can be.

So mplayer .debs would depend on libsmbclient. libsmbclient:i386 can't co-exist with the 64 bit...