I had a similar issue too. I solved this problem by the method linked below.
https://unix.stackexchange.com/questions/290836/how-do-i-update-ubuntu-when-package-system-is-broken