The dependency problem is because it depends on libmagick++2, while recent versions of Ubuntu only have libmagick++3.

You can get a copy of libmagick++2 from the lucid repos here. Install the .deb...