The package probably needs the internet to install.

Try the following and it should list the internet controller info near the bottom of the output.

lspci