10.04 is no longer supported, you need to move up to 12.04 or 14.04 for the LTS versions.