Your kernel may be to old for the required AMD driver but so far you have not mentioned what kernel version you are actually using.
Installinga later HWE kernel version may be all that's needed but...