In response to the perl locale problems mentioned earlier (perl: warning: Setting locale failed), installing language-pack-en-base seemed to fix it for me.