Zesty was 17.04. You definitely shouldn't be using any zesty repositories.