This patch works for me as well on gentoo with gtk+-2.12, gnome-macmenu-applet-1.0.4 and gnome-2.20.