Libpoppler85 should indeed not be upgraded. I found the same issue, and shown from apt install libpoppler85:

The following packages were automatically installed and are no longer required:
...