are you using python 2.x or 3.x? just curious